summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-09-23 18:05:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-09-23 18:05:42 +0000
commit86d509f0f5874666f9f8d1b498b55ab51ec2edc9 (patch)
tree28f0d80c43c1bca47e0537268460e2f54e1d8665 /games-util/ucon64
parentVersion bump (diff)
downloadgentoo-2-86d509f0f5874666f9f8d1b498b55ab51ec2edc9.tar.gz
gentoo-2-86d509f0f5874666f9f8d1b498b55ab51ec2edc9.tar.bz2
gentoo-2-86d509f0f5874666f9f8d1b498b55ab51ec2edc9.zip
Build with new zlib. Bug #383813
(Portage version: 2.1.10.19/cvs/Linux i686)
Diffstat (limited to 'games-util/ucon64')
-rw-r--r--games-util/ucon64/ChangeLog8
-rw-r--r--games-util/ucon64/files/ucon64-2.0.0-zlib.patch25
-rw-r--r--games-util/ucon64/ucon64-2.0.0.ebuild7
3 files changed, 35 insertions, 5 deletions
diff --git a/games-util/ucon64/ChangeLog b/games-util/ucon64/ChangeLog
index b57548984443..ce91d96ed7aa 100644
--- a/games-util/ucon64/ChangeLog
+++ b/games-util/ucon64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/ucon64
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ChangeLog,v 1.14 2010/11/04 08:20:12 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ChangeLog,v 1.15 2011/09/23 18:05:42 tupone Exp $
+
+ 23 Sep 2011; Tupone Alfredo <tupone@gentoo.org> ucon64-2.0.0.ebuild,
+ +files/ucon64-2.0.0-zlib.patch:
+ Build with new zlib. Bug #383813 by Diego Elio Pettenò
04 Nov 2010; Tupone Alfredo <tupone@gentoo.org> ucon64-2.0.0.ebuild,
+files/ucon64-2.0.0-ovflfix.patch:
diff --git a/games-util/ucon64/files/ucon64-2.0.0-zlib.patch b/games-util/ucon64/files/ucon64-2.0.0-zlib.patch
new file mode 100644
index 000000000000..f7a371ab69ec
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.0.0-zlib.patch
@@ -0,0 +1,25 @@
+--- misc/unzip.h.old 2011-09-23 19:53:09.708884325 +0200
++++ misc/unzip.h 2011-09-23 19:54:00.012878355 +0200
+@@ -49,6 +49,10 @@
+ #include "zlib.h"
+ #endif
+
++#ifndef OF
++#define OF(x) x
++#endif
++
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+ from (void*) without cast */
+--- libdiscmage/unzip.h.old 2011-09-23 19:59:47.319837133 +0200
++++ libdiscmage/unzip.h 2011-09-23 20:00:07.230834769 +0200
+@@ -48,6 +48,9 @@
+ #ifndef _ZLIB_H
+ #include "zlib.h"
+ #endif
++#ifndef OF
++#define OF(x) x
++#endif
+
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
diff --git a/games-util/ucon64/ucon64-2.0.0.ebuild b/games-util/ucon64/ucon64-2.0.0.ebuild
index 880d5f0ae4c5..b7eda810d728 100644
--- a/games-util/ucon64/ucon64-2.0.0.ebuild
+++ b/games-util/ucon64/ucon64-2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ucon64-2.0.0.ebuild,v 1.9 2010/11/04 08:20:12 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ucon64-2.0.0.ebuild,v 1.10 2011/09/23 18:05:42 tupone Exp $
EAPI=2
inherit eutils
@@ -19,7 +19,8 @@ DEPEND=""
S=${WORKDIR}/${P}-src/src
src_prepare() {
- epatch "${FILESDIR}"/${P}-ovflfix.patch
+ epatch "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-zlib.patch
sed -i \
-e "/^CFLAGS/s/-O3/${CFLAGS}/" \
-e "/^LDFLAGS/s/-s$/${LDFLAGS}/" \