summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-14 05:32:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-14 05:32:03 +0000
commit21c610cceb8c42e2873ed8a5c6628328c6566291 (patch)
tree416084e3438d22a64cc623c7a0c7f1b10c76455f /games-util
parentSet PIDFILE and CONFFILE init script parameters to values based on service na... (diff)
downloadgentoo-2-21c610cceb8c42e2873ed8a5c6628328c6566291.tar.gz
gentoo-2-21c610cceb8c42e2873ed8a5c6628328c6566291.tar.bz2
gentoo-2-21c610cceb8c42e2873ed8a5c6628328c6566291.zip
add device to build (bug #199116) with patch from Brandon Captain and patch to address the cpu burn loop (bug #197135) from Martin Berkemeier.
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/qjoypad/ChangeLog7
-rw-r--r--games-util/qjoypad/files/qjoypad-3.4.1-busy.patch11
-rw-r--r--games-util/qjoypad/qjoypad-3.4.1.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/games-util/qjoypad/ChangeLog b/games-util/qjoypad/ChangeLog
index b8ca96c0152d..5b5fa02bfb6b 100644
--- a/games-util/qjoypad/ChangeLog
+++ b/games-util/qjoypad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/qjoypad
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/qjoypad/ChangeLog,v 1.8 2007/11/10 01:16:04 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/qjoypad/ChangeLog,v 1.9 2007/11/14 05:32:03 mr_bones_ Exp $
+
+ 14 Nov 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/qjoypad-3.4.1-busy.patch, qjoypad-3.4.1.ebuild:
+ add device to build (bug #199116) with patch from Brandon Captain and patch to
+ address the cpu burn loop (bug #197135) from Martin Berkemeier.
*qjoypad-3.4.1 (10 Nov 2007)
diff --git a/games-util/qjoypad/files/qjoypad-3.4.1-busy.patch b/games-util/qjoypad/files/qjoypad-3.4.1-busy.patch
new file mode 100644
index 000000000000..40a9f8dffb9f
--- /dev/null
+++ b/games-util/qjoypad/files/qjoypad-3.4.1-busy.patch
@@ -0,0 +1,11 @@
+--- qjoypad-3.4.orig/src/loop.cpp 2004-08-17 16:30:19.000000000 +0200
++++ qjoypad-3.4/src/loop.cpp 2007-10-26 16:40:41.000000000 +0200
+@@ -31,7 +31,7 @@ bool JoyLoop::processEvents( ProcessEven
+
+ //sleep for a moment. This is just to keep us from throwing all the
+ //available processer power into madly checking for new events.
+- usleep(1);
++ usleep(10000);
+
+ //now we can let QT process all of its events, like GUI events and timers.
+ return QEventLoop::processEvents(AllEvents);
diff --git a/games-util/qjoypad/qjoypad-3.4.1.ebuild b/games-util/qjoypad/qjoypad-3.4.1.ebuild
index 622d93cc30a6..20f19f1df82a 100644
--- a/games-util/qjoypad/qjoypad-3.4.1.ebuild
+++ b/games-util/qjoypad/qjoypad-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/qjoypad/qjoypad-3.4.1.ebuild,v 1.1 2007/11/10 01:16:04 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/qjoypad/qjoypad-3.4.1.ebuild,v 1.2 2007/11/14 05:32:03 mr_bones_ Exp $
inherit qt3 eutils
@@ -28,11 +28,12 @@ src_unpack() {
-e "/^CXXFLAGS/s:-pipe -Wall -W -O2:${CXXFLAGS}:" \
-e '/^Makefile:/s|:.*||' \
Makefile || die "sed make depends failed"
+ epatch "${FILESDIR}/${P}-busy.patch"
}
src_compile() {
cd src
- eqmake3 qjoypad.pro PREFIX=/usr
+ eqmake3 qjoypad.pro PREFIX=/usr DEVDIR=/dev/input
emake || die "emake failed"
}