summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-01-29 00:27:30 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-01-29 00:27:30 +0000
commit642ecd1837e0ac7aad67bcf4b0d1c6f7120a18ea (patch)
treed6d4a797073a4f7955701ed793d44db0c61c7595 /games-util
parentFix bug 421325: Fixed by version bump (diff)
downloadgentoo-2-642ecd1837e0ac7aad67bcf4b0d1c6f7120a18ea.tar.gz
gentoo-2-642ecd1837e0ac7aad67bcf4b0d1c6f7120a18ea.tar.bz2
gentoo-2-642ecd1837e0ac7aad67bcf4b0d1c6f7120a18ea.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/ChangeLog9
-rw-r--r--games-util/lutris/lutris-0.3.3.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/games-util/lutris/ChangeLog b/games-util/lutris/ChangeLog
index ecb8988370e7..b988578c22d4 100644
--- a/games-util/lutris/ChangeLog
+++ b/games-util/lutris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/lutris
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/lutris/ChangeLog,v 1.2 2013/12/27 15:15:45 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/lutris/ChangeLog,v 1.3 2014/01/29 00:27:30 hasufell Exp $
+
+*lutris-0.3.3 (29 Jan 2014)
+
+ 29 Jan 2014; Julian Ospald <hasufell@gentoo.org> +lutris-0.3.3.ebuild:
+ version bump
27 Dec 2013; Julian Ospald <hasufell@gentoo.org> lutris-0.3.2.ebuild:
fix dependencies
diff --git a/games-util/lutris/lutris-0.3.3.ebuild b/games-util/lutris/lutris-0.3.3.ebuild
new file mode 100644
index 000000000000..eaf3eec187b1
--- /dev/null
+++ b/games-util/lutris/lutris-0.3.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/lutris/lutris-0.3.3.ebuild,v 1.1 2014/01/29 00:27:30 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils games
+
+DESCRIPTION="Gaming platform for GNU/Linux"
+HOMEPAGE="http://lutris.net/"
+SRC_URI="https://github.com/lutris/lutris/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ gnome-base/gvfs[http]"
+
+# INSTALL contains list of optional deps
+DOCS=( AUTHORS README INSTALL )
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional deps (runners), see"
+ elog "/usr/share/doc/${PF}/INSTALL"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}