summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-17 16:04:36 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-17 16:04:36 +0000
commit7ec2ac09646988e2a2dc356f50a4eb4e2dfd967e (patch)
tree5cacdffb85007519bc3af62aaa60ba0d749e29a2 /games-util
parentRequest built-in Python sqlite3 support rather than pysqlite package. (diff)
downloadgentoo-2-7ec2ac09646988e2a2dc356f50a4eb4e2dfd967e.tar.gz
gentoo-2-7ec2ac09646988e2a2dc356f50a4eb4e2dfd967e.tar.bz2
gentoo-2-7ec2ac09646988e2a2dc356f50a4eb4e2dfd967e.zip
migrate to distutils-r1
(Portage version: 2.2.0_alpha153/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/ChangeLog9
-rw-r--r--games-util/nml/nml-0.2.4-r1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/games-util/nml/ChangeLog b/games-util/nml/ChangeLog
index 6a7b37bb7030..6380ec099c40 100644
--- a/games-util/nml/ChangeLog
+++ b/games-util/nml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/nml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/nml/ChangeLog,v 1.10 2012/12/31 16:32:33 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/nml/ChangeLog,v 1.11 2013/01/17 16:04:36 hasufell Exp $
+
+*nml-0.2.4-r1 (17 Jan 2013)
+
+ 17 Jan 2013; Julian Ospald <hasufell@gentoo.org> +nml-0.2.4-r1.ebuild:
+ migrate to distutils-r1
31 Dec 2012; Agostino Sarubbo <ago@gentoo.org> nml-0.2.3.ebuild:
Add ~ppc64, wrt bug #412329
diff --git a/games-util/nml/nml-0.2.4-r1.ebuild b/games-util/nml/nml-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..40608c327c34
--- /dev/null
+++ b/games-util/nml/nml-0.2.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/nml/nml-0.2.4-r1.ebuild,v 1.1 2013/01/17 16:04:36 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/imaging
+ dev-python/ply"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}