summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-11 19:28:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-11 19:28:17 +0000
commitea7c8c93f992959834f084b7e7ea70f1d0b52183 (patch)
treee106ae8629a1cf71071861742e251080a3cd3dfa /games-util
parentRemove kde-base/kdelibs:3.5 support. (diff)
downloadgentoo-2-ea7c8c93f992959834f084b7e7ea70f1d0b52183.tar.gz
gentoo-2-ea7c8c93f992959834f084b7e7ea70f1d0b52183.tar.bz2
gentoo-2-ea7c8c93f992959834f084b7e7ea70f1d0b52183.zip
add live svn ebuild submitted by Jan Vansteenkiste via bug #284903
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/linux-wbfs-manager/ChangeLog8
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/games-util/linux-wbfs-manager/ChangeLog b/games-util/linux-wbfs-manager/ChangeLog
index 40e397306c8e..10c572559ef5 100644
--- a/games-util/linux-wbfs-manager/ChangeLog
+++ b/games-util/linux-wbfs-manager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/linux-wbfs-manager
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/ChangeLog,v 1.2 2009/09/05 04:06:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/ChangeLog,v 1.3 2009/11/11 19:28:17 mr_bones_ Exp $
+
+*linux-wbfs-manager-9999 (11 Nov 2009)
+
+ 11 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +linux-wbfs-manager-9999.ebuild:
+ add live svn ebuild submitted by Jan Vansteenkiste via bug #284903
*linux-wbfs-manager-0.1.11 (05 Sep 2009)
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
new file mode 100644
index 000000000000..d54d6ca4444d
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild,v 1.1 2009/11/11 19:28:17 mr_bones_ Exp $
+
+EAPI=2
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="http://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="http://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="http://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin wbfs_gtk || die
+ dodoc README
+}