summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-11-12 15:58:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-11-12 15:58:23 +0000
commiteeb6a0f1f04de239fe008627984848d820d97a7a (patch)
tree37c77e4830f12a7fcfacd1fc557e983976ace2f8 /games-util
parentVersion bump with new homepage, also fixes bug #514220 (diff)
downloadgentoo-2-eeb6a0f1f04de239fe008627984848d820d97a7a.tar.gz
gentoo-2-eeb6a0f1f04de239fe008627984848d820d97a7a.tar.bz2
gentoo-2-eeb6a0f1f04de239fe008627984848d820d97a7a.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/dfarc/ChangeLog9
-rw-r--r--games-util/dfarc/dfarc-3.12.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/games-util/dfarc/ChangeLog b/games-util/dfarc/ChangeLog
index 9007b1769ee0..80dd99366ae8 100644
--- a/games-util/dfarc/ChangeLog
+++ b/games-util/dfarc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/dfarc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/dfarc/ChangeLog,v 1.4 2013/09/14 20:13:45 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/dfarc/ChangeLog,v 1.5 2014/11/12 15:58:23 hasufell Exp $
+
+*dfarc-3.12 (12 Nov 2014)
+
+ 12 Nov 2014; Julian Ospald <hasufell@gentoo.org> +dfarc-3.12.ebuild:
+ version bump
14 Sep 2013; Julian Ospald <hasufell@gentoo.org> dfarc-3.10.ebuild:
correct license info
diff --git a/games-util/dfarc/dfarc-3.12.ebuild b/games-util/dfarc/dfarc-3.12.ebuild
new file mode 100644
index 000000000000..8c9919ee2062
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/dfarc/dfarc-3.12.ebuild,v 1.1 2014/11/12 15:58:23 hasufell Exp $
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+inherit gnome2-utils fdo-mime wxwidgets games
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.freedink.org/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}"
+DEPEND="${RDEPEND}
+ nls? ( >=dev-util/intltool-0.31 )"
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls) \
+ --disable-desktopfiles
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}