summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-26 03:40:42 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-26 03:40:42 +0000
commitf0a60e32c291115cb58cb00f89aeffe9cf1c6cc3 (patch)
tree46f221fbe8b2913ec16831fc45bf806b75a5bb42 /games-util
parentFix typo from tests (diff)
downloadgentoo-2-f0a60e32c291115cb58cb00f89aeffe9cf1c6cc3.tar.gz
gentoo-2-f0a60e32c291115cb58cb00f89aeffe9cf1c6cc3.tar.bz2
gentoo-2-f0a60e32c291115cb58cb00f89aeffe9cf1c6cc3.zip
Bump. Adds Crucible 1.0.2 updates, proxy support, bugfixes and UI improvements. Install icons in all available sizes. Drop obsolete version.
(Portage version: 2.2.0_alpha83/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/pyfa/ChangeLog9
-rw-r--r--games-util/pyfa/files/pyfa-1.0.3-staticPath.patch15
-rw-r--r--games-util/pyfa/pyfa-1.1.1.ebuild (renamed from games-util/pyfa/pyfa-1.0.6.ebuild)19
3 files changed, 22 insertions, 21 deletions
diff --git a/games-util/pyfa/ChangeLog b/games-util/pyfa/ChangeLog
index 470d140c906c..1e8bcc32de9d 100644
--- a/games-util/pyfa/ChangeLog
+++ b/games-util/pyfa/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-util/pyfa
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.2 2011/11/30 18:33:25 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.3 2011/12/26 03:40:41 tetromino Exp $
+
+*pyfa-1.1.1 (26 Dec 2011)
+
+ 26 Dec 2011; Alexandre Rostovtsev (tetromino) <tetromino@gmail.com>
+ -files/pyfa-1.0.3-staticPath.patch, -pyfa-1.0.6.ebuild, +pyfa-1.1.1.ebuild:
+ Bump. Adds Crucible 1.0.2 updates, proxy support, bugfixes and UI
+ improvements. Install icons in all available sizes. Drop obsolete version.
*pyfa-1.1 (30 Nov 2011)
diff --git a/games-util/pyfa/files/pyfa-1.0.3-staticPath.patch b/games-util/pyfa/files/pyfa-1.0.3-staticPath.patch
deleted file mode 100644
index 4eff73006c62..000000000000
--- a/games-util/pyfa/files/pyfa-1.0.3-staticPath.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Make staticPath settable from configforced
-
---- a/config.py
-+++ b/config.py
-@@ -30,7 +30,9 @@ if savePath is None:
- savePath = unicode(os.path.expanduser(os.path.join("~", ".pyfa")), sys.getfilesystemencoding())
-
- # Static EVE Data from the staticdata repository, should be in the staticdata directory in our pyfa directory
--staticPath = os.path.join(pyfaPath, "staticdata")
-+staticPath = getattr(configforced, "staticPath", None)
-+if staticPath is None:
-+ staticPath = os.path.join(pyfaPath, "staticdata")
-
- # The database where we store all the fits etc
- saveDB = os.path.join(savePath, "saveddata.db")
diff --git a/games-util/pyfa/pyfa-1.0.6.ebuild b/games-util/pyfa/pyfa-1.1.1.ebuild
index e73a95f79917..7f89f74c09e4 100644
--- a/games-util/pyfa/pyfa-1.0.6.ebuild
+++ b/games-util/pyfa/pyfa-1.1.1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.0.6.ebuild,v 1.1 2011/11/02 23:59:34 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.1.1.ebuild,v 1.1 2011/12/26 03:40:41 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
PYTHON_USE_WITH="sqlite threads"
-inherit eutils python
+inherit eutils gnome2-utils python
if [[ ${PV/_rc*/} == ${PV} ]] ; then
- MY_PV=${PV}-incarna-src
+ MY_PV=${PV}-crucible-src
FOLDER=stable/${PV}
else
MY_PV=${PV/_rc/-stable-RC}-src
@@ -39,7 +39,7 @@ pkg_setup() {
src_prepare() {
# make staticPath settable from configforced again
- epatch "${FILESDIR}/${PN}-1.0.3-staticPath.patch"
+ epatch "${FILESDIR}/${PN}-1.1-staticPath.patch"
python_convert_shebangs -r -x 2 .
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
@@ -57,14 +57,23 @@ src_install() {
insinto /usr/share/${PN}
doins -r staticdata
dodoc readme.txt
- doicon icons/${PN}.png
+ insinto /usr/share/icons/hicolor/32x32/apps
+ doins icons/pyfa.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins icons/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
+ gnome2_icon_cache_update
python_mod_optimize ${PN}
}
pkg_postrm() {
+ gnome2_icon_cache_update
python_mod_cleanup ${PN}
}