summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-11-03 01:45:56 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-11-03 01:45:56 +0000
commit22a63123a8fbdf98e7b9750018fcb0491746c725 (patch)
treeeaa023bac49561e1f4dbfea764f6be891a35697e /gnome-base/ORBit
parentnew version (diff)
downloadgentoo-2-22a63123a8fbdf98e7b9750018fcb0491746c725.tar.gz
gentoo-2-22a63123a8fbdf98e7b9750018fcb0491746c725.tar.bz2
gentoo-2-22a63123a8fbdf98e7b9750018fcb0491746c725.zip
removed buggy gdk-pixbuf; updated bonobo and ORBit, but since it can cause problems with evolution, masked it
Diffstat (limited to 'gnome-base/ORBit')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.12.ebuild53
-rw-r--r--gnome-base/ORBit/files/digest-ORBit-0.5.121
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.12.ebuild b/gnome-base/ORBit/ORBit-0.5.12.ebuild
new file mode 100644
index 000000000000..dd770d5b1dd4
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.12.ebuild,v 1.1 2001/11/03 01:45:56 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+}
+
+
+
diff --git a/gnome-base/ORBit/files/digest-ORBit-0.5.12 b/gnome-base/ORBit/files/digest-ORBit-0.5.12
new file mode 100644
index 000000000000..4b08ca67bb4f
--- /dev/null
+++ b/gnome-base/ORBit/files/digest-ORBit-0.5.12
@@ -0,0 +1 @@
+MD5 ab66859c937a940da6bad2c84161c6aa ORBit-0.5.12.tar.gz 1294336