summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-20 19:59:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-20 19:59:44 +0000
commit4302df5161bb7c25fcb9f43ad452ef61fe50f0eb (patch)
tree0fbc5247a65a7813dacab97e264e3e1b926c3d43 /gnome-base/gconf
parentVersion bump (diff)
downloadgentoo-2-4302df5161bb7c25fcb9f43ad452ef61fe50f0eb.tar.gz
gentoo-2-4302df5161bb7c25fcb9f43ad452ef61fe50f0eb.tar.bz2
gentoo-2-4302df5161bb7c25fcb9f43ad452ef61fe50f0eb.zip
New version for GNOME 2.24. Integrates with dbus, optional policykit support.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog10
-rw-r--r--gnome-base/gconf/files/gconf-2.24.0-automagic-ldap.patch90
-rw-r--r--gnome-base/gconf/files/gconf-2.24.0-no-gconfd.patch19
-rw-r--r--gnome-base/gconf/gconf-2.24.0.ebuild100
4 files changed, 218 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 4104dd3f2329..d6f73f601a7e 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.196 2008/09/25 14:10:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.197 2008/10/20 19:59:44 eva Exp $
+
+*gconf-2.24.0 (20 Oct 2008)
+
+ 20 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gconf-2.24.0-automagic-ldap.patch,
+ +files/gconf-2.24.0-no-gconfd.patch, +gconf-2.24.0.ebuild:
+ New version for GNOME 2.24. Integrates with dbus, optional policykit
+ support.
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> gconf-2.22.0.ebuild:
Stable for HPPA (bug #236971).
diff --git a/gnome-base/gconf/files/gconf-2.24.0-automagic-ldap.patch b/gnome-base/gconf/files/gconf-2.24.0-automagic-ldap.patch
new file mode 100644
index 000000000000..678c5fb58832
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-2.24.0-automagic-ldap.patch
@@ -0,0 +1,90 @@
+---
+ * make openldap support optional and auto-detected
+
+ configure.in | 65 +++++++++++++++++++++++++++++++++++++++--------------------
+ 1 file changed, 43 insertions(+), 22 deletions(-)
+
+Index: b/configure.in
+===================================================================
+--- a/configure.in
++++ b/configure.in
+@@ -207,36 +207,57 @@ AC_CHECK_HEADERS(syslog.h sys/wait.h)
+
+ AC_CHECK_FUNCS(getuid sigaction fsync fchmod fdwalk)
+
++dnl **************************************************
++dnl LDAP support.
++dnl **************************************************
++
++AC_ARG_WITH(openldap,
++ AS_HELP_STRING([--with-openldap],
++ [Enable LDAP backend @<:@default=auto@:>@]),
++ ,with_openldap=auto)
+
+ LDAP_LIBS=
+-AC_CHECK_HEADER(ldap.h, [
++
++if test "x$with_openldap" != "xno"; then
++ AC_CHECK_HEADER(ldap.h, [
+ AC_CHECK_LIB(ldap, ldap_init, AC_CHECK_LIB(lber, ber_free, [LDAP_LIBS="-lldap -llber"]))
+ ])
+-AC_SUBST(LDAP_LIBS)
+-AM_CONDITIONAL(LDAP_SUPPORT, test -n "$LDAP_LIBS")
+
+-dnl **************************************************
+-dnl LDAP support.
+-dnl **************************************************
+-if test "$os_win32" != yes; then
++ if test "x$os_win32" != "xyes"; then
++ SAVE_CFLAGS="$CFLAGS"
++ SAVE_LIBS="$LIBS"
++ LDAP_CFLAGS="-DLDAP_DEPRECATED"
++ CFLAGS="$CFLAGS $LDAP_CFLAGS"
++ LIBS="$LIBS $LDAP_LIBS"
++ AC_CHECK_FUNCS(ldap_ntlm_bind)
++ CFLAGS="$SAVE_CFLAGS"
++ LIBS="$SAVE_LIBS"
++
++ else # Win32
++ LDAP_CFLAGS="-DLDAP_DEPRECATED"
++ LDAP_LIBS="-lwldap32"
++ AC_SUBST(LDAP_CFLAGS)
++ AC_SUBST(LDAP_LIBS)
++ AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
++ msg_ldap="yes"
++
++ fi # Win32
++
++ if test -z "$LDAP_LIBS"; then
++ if test "x$with_openldap" = "xyes"; then
++ AC_MSG_ERROR([*** LDAP support explicitely requested but not found ***])
++ else
++ AC_MSG_WARN([*** LDAP support not found ***])
++ fi
++ fi
+
+-SAVE_CFLAGS="$CFLAGS"
+-SAVE_LIBS="$LIBS"
+-LDAP_CFLAGS="-DLDAP_DEPRECATED"
+-CFLAGS="$CFLAGS $LDAP_CFLAGS"
+-LIBS="$LIBS $LDAP_LIBS"
+-AC_CHECK_FUNCS(ldap_ntlm_bind)
+-CFLAGS="$SAVE_CFLAGS"
+-LIBS="$SAVE_LIBS"
+-
+-else # Win32
+-LDAP_CFLAGS="-DLDAP_DEPRECATED"
+-LDAP_LIBS="-lwldap32"
++ have_ldap=yes
++else
++ have_ldap=no
++fi
+ AC_SUBST(LDAP_CFLAGS)
+ AC_SUBST(LDAP_LIBS)
+-AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
+-msg_ldap="yes"
+-fi # Win32
++AM_CONDITIONAL(LDAP_SUPPORT, [test -n "$LDAP_LIBS"])
+
+ IT_PROG_INTLTOOL([0.35.0])
+
diff --git a/gnome-base/gconf/files/gconf-2.24.0-no-gconfd.patch b/gnome-base/gconf/files/gconf-2.24.0-no-gconfd.patch
new file mode 100644
index 000000000000..8ca6a0d4fc09
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-2.24.0-no-gconfd.patch
@@ -0,0 +1,19 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN GConf-2.23.2.old/gconf/gconftool.c GConf-2.23.2/gconf/gconftool.c
+--- GConf-2.23.2.old/gconf/gconftool.c 2008-06-28 05:27:33.000000000 -0400
++++ GConf-2.23.2/gconf/gconftool.c 2008-09-23 10:20:00.000000000 -0400
+@@ -856,6 +856,7 @@ main (int argc, char** argv)
+ {
+ g_print (_("GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL is set, not installing schemas\n"));
+ makefile_install_mode = FALSE;
++ return 0;
+ }
+
+ if (makefile_uninstall_mode &&
+@@ -863,6 +864,7 @@ main (int argc, char** argv)
+ {
+ g_print (_("GCONF_DISABLE_MAKEFILE_SCHEMA_UNINSTALL is set, not uninstalling schemas\n"));
+ makefile_uninstall_mode = FALSE;
++ return 0;
+ }
+
+ if (makefile_install_mode || makefile_uninstall_mode)
diff --git a/gnome-base/gconf/gconf-2.24.0.ebuild b/gnome-base/gconf/gconf-2.24.0.ebuild
new file mode 100644
index 000000000000..fe8ba16ee98b
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.24.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.24.0.ebuild,v 1.1 2008/10/20 19:59:44 eva Exp $
+
+inherit autotools eutils gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc ldap"
+
+# FIXME: add policykit support
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.8.16
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gtk
+ --disable-defaults-service
+ $(use_enable debug)
+ $(use_with ldap openldap)"
+ #$(use_enable policykit defaults-service)
+ kill_gconf
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #193442, GNOME bug #498934
+ epatch "${FILESDIR}/${P}-automagic-ldap.patch"
+
+ # fix bug #238276
+ epatch "${FILESDIR}/${P}-no-gconfd.patch"
+
+ eautoreconf
+}
+
+# Can't run tests, missing script.
+#src_test() {
+# emake -C tests || die "make tests failed"
+# sh "${S}"/tests/runtests.sh || die "running tests failed"
+#}
+
+src_install() {
+ gnome2_src_install
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die "doenv failed"
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}