summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-23 09:37:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-23 09:37:34 +0000
commitba3135a00cf48256f520dc4077078cb1e116b77b (patch)
tree9eaaa54b670a990f527f7bcc569165219a9aed3b /gnome-base/gnome-libs
parentadded ppc to keywords of fluxconf-0.8.5.ebuild (diff)
downloadgentoo-2-ba3135a00cf48256f520dc4077078cb1e116b77b.tar.gz
gentoo-2-ba3135a00cf48256f520dc4077078cb1e116b77b.tar.bz2
gentoo-2-ba3135a00cf48256f520dc4077078cb1e116b77b.zip
cleaned up ebuild
Diffstat (limited to 'gnome-base/gnome-libs')
-rw-r--r--gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild43
1 files changed, 16 insertions, 27 deletions
diff --git a/gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild b/gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild
index a4522286d82f..76c242cbb7a6 100644
--- a/gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild
+++ b/gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild,v 1.7 2002/08/16 04:09:22 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.1.7.ebuild,v 1.8 2002/08/23 09:37:34 seemant Exp $
+
+inherit libtool
S=${WORKDIR}/${P}
DESCRIPTION="GNOME Core Libraries"
@@ -10,12 +12,12 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
DEPEND=">=media-libs/imlib-1.9.10
- >=media-sound/esound-0.2.23
- >=gnome-base/ORBit-0.5.12
- =x11-libs/gtk+-1.2*
- <sys-libs/db-2
- doc? ( app-text/docbook-sgml
- dev-util/gtk-doc )"
+ >=media-sound/esound-0.2.23
+ >=gnome-base/ORBit-0.5.12
+ =x11-libs/gtk+-1.2*
+ <sys-libs/db-2
+ doc? ( app-text/docbook-sgml
+ dev-util/gtk-doc )"
RDEPEND="nls? ( >=sys-devel/gettext-0.10.40 >=dev-util/intltool-0.11 )"
@@ -31,20 +33,15 @@ src_compile() {
use doc || myconf="${myconf} --disable-gtk-doc"
# libtoolize
- libtoolize --copy --force
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
+ elibtoolize
+
+ econf \
--enable-prefer-db1 \
${myconf} || die
emake || die
- #do the docs (maby add a use variable or put in seperate
+ #do the docs (maybe add a use variable or put in seperate
#ebuild since it is mostly developer docs?)
if [ -n "`use doc`" ]
then
@@ -55,23 +52,16 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
+ einstall \
docdir=${D}/usr/share/doc \
HTML_DIR=${D}/usr/share/gnome/html \
- install || die
+ || die
#do the docs
if [ -n "`use doc`" ]
then
cd ${S}/devel-docs
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- docdir=${D}/usr/share/doc \
- install || die
+ einstall || die
cd ${S}
fi
@@ -79,4 +69,3 @@ src_install() {
dodoc AUTHORS COPYING* ChangeLog README NEWS HACKING
}
-