summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-10-24 19:07:16 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-10-24 19:07:16 +0000
commit835c22a301df7ea0369ee558e40b05b98ac628e8 (patch)
tree99614c66879c914a4b24fe91a8a177c69f5a3858 /gnome-base/libgnomeprint
parentremoved syslog-ng mask and cleanups (diff)
downloadgentoo-2-835c22a301df7ea0369ee558e40b05b98ac628e8.tar.gz
gentoo-2-835c22a301df7ea0369ee558e40b05b98ac628e8.tar.bz2
gentoo-2-835c22a301df7ea0369ee558e40b05b98ac628e8.zip
new version with the gnome.org eclas
Diffstat (limited to 'gnome-base/libgnomeprint')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog7
-rw-r--r--gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.11
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-1.116.1.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index 9c5673c09372..b823c2d2a63b 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for gnome-extra/libgnomeprint
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.6 2002/08/05 19:58:50 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.7 2002/10/24 19:07:16 spider Exp $
+*libgnomeprint-1.116.1 (24 Oct 2002)
+
+ 24 Oct 2002; Spider <spider@gentoo.org> libgnomeprint-1.116.1.ebuild :
+ new version, minor update and using gnome.org eclass now
+
*libgnomeprint-1.116.0 (05 Aug 2002)
05 Aug 2002; Spider <spider@gentoo.org> libgnomeprint-1.116.0.ebuild :
experimented with gnome2.eclass but it failed with sandbox errors.
diff --git a/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.1 b/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.1
new file mode 100644
index 000000000000..503967575105
--- /dev/null
+++ b/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.1
@@ -0,0 +1 @@
+MD5 de58f804997e1bb39b06661e4fb2dcd2 libgnomeprint-1.116.1.tar.bz2 485590
diff --git a/gnome-base/libgnomeprint/libgnomeprint-1.116.1.ebuild b/gnome-base/libgnomeprint/libgnomeprint-1.116.1.ebuild
new file mode 100644
index 000000000000..568764ab7140
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-1.116.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-1.116.1.ebuild,v 1.1 2002/10/24 19:07:16 spider Exp $
+
+
+inherit libtool gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Printer handling for Gnome"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+LICENSE="GPL-2 LGPL-2.1"
+
+
+RDEPEND=">=gnome-base/libbonobo-2.0.0
+ >=media-libs/libart_lgpl-2.3.8
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/libxml2-2.4.22
+ >=dev-libs/glib-2.0.0
+ >=media-libs/freetype-2.0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --disable-font-install \
+ --enable-platform-gnome-2 \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog* INSTALL NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Fonts"
+ libgnomeprint-2.0-font-install \
+ --debug \
+ --smart \
+ --static \
+ --aliases=/usr/share/gnome/libgnomeprint-2.0/fonts/adobe-urw.font \
+ --target=/usr/share/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
+
+}