summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2004-11-10 02:44:38 +0000
committerMike Gardiner <obz@gentoo.org>2004-11-10 02:44:38 +0000
commit7b3334893fdd90abe04752b75edde1e72c1d3abf (patch)
treecd7c902dbf253ff89fca4a1b8a8add01576ee1d7 /gnome-base/nautilus/files
parentClean up ebuilds and add support for maketest (#68643). Also add misc patche... (diff)
downloadgentoo-2-7b3334893fdd90abe04752b75edde1e72c1d3abf.tar.gz
gentoo-2-7b3334893fdd90abe04752b75edde1e72c1d3abf.tar.bz2
gentoo-2-7b3334893fdd90abe04752b75edde1e72c1d3abf.zip
Applied patch for building with libexif-0.6.10
Diffstat (limited to 'gnome-base/nautilus/files')
-rw-r--r--gnome-base/nautilus/files/nautilus-2-libexif.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnome-base/nautilus/files/nautilus-2-libexif.patch b/gnome-base/nautilus/files/nautilus-2-libexif.patch
new file mode 100644
index 000000000000..161ef006e01c
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-2-libexif.patch
@@ -0,0 +1,64 @@
+--- acconfig.h
++++ acconfig.h
+@@ -23,3 +23,4 @@
+ #define HAVE_GTK_MULTIHEAD /* needed for egg-screen-exec functions */
+ #undef HAVE_STARTUP_NOTIFICATION
+ #undef HAVE_EXIF
++#undef HAVE_OLD_EXIF
+--- components/image_properties/nautilus-image-properties-view.c
++++ components/image_properties/nautilus-image-properties-view.c
+@@ -124,13 +124,20 @@
+ exif_content_callback (ExifContent *content, gpointer data)
+ {
+ struct ExifAttribute *attribute;
++#if !HAVE_OLD_EXIF
++ char b[1024];
++#endif
+
+ attribute = (struct ExifAttribute *)data;
+ if (attribute->found) {
+ return;
+ }
+
++#ifdef HAVE_OLD_EXIF
+ attribute->value = g_strdup (exif_content_get_value (content, attribute->tag));
++#else
++ attribute->value = g_strdup (exif_content_get_value (content, attribute->tag, b, sizeof(b)));
++#endif
+ if (attribute->value != NULL) {
+ attribute->found = TRUE;
+ }
+--- configure.in
++++ configure.in
+@@ -20,7 +20,6 @@
+ RSVG_REQUIRED=2.0.1
+ XML_REQUIRED=2.4.7
+ STARTUP_NOTIFICATION_REQUIRED=0.5
+-EXIF_REQUIRED=0.5.12
+
+ AC_SUBST(ART_REQUIRED)
+ AC_SUBST(BONOBO_ACTIVATION_REQUIRED)
+@@ -228,12 +227,17 @@
+
+ AC_MSG_CHECKING(for libExif)
+
+-PKG_CHECK_MODULES(EXIF, libexif >= $EXIF_REQUIRED, have_exif=yes, have_exif=no)
+-if test "x$have_exif" = "xyes"; then
+- AC_DEFINE(HAVE_EXIF,1)
+- AC_SUBST(EXIF_CFLAGS)
+- AC_SUBST(EXIF_LIBS)
+-fi
++PKG_CHECK_MODULES(EXIF, libexif > 0.5.12, [
++ AC_DEFINE(HAVE_EXIF, 1, [Define to 1 if you have EXIF library (libexif).])
++ AC_SUBST(EXIF_CFLAGS)
++ AC_SUBST(EXIF_LIBS)
++ ], [
++ PKG_CHECK_MODULES(EXIF, libexif = 0.5.12, [
++ AC_DEFINE(HAVE_EXIF, 1)
++ AC_DEFINE(HAVE_OLD_EXIF, 1, [Define to 1 if your EXIF library has old API.])
++ AC_SUBST(EXIF_CFLAGS)
++ AC_SUBST(EXIF_LIBS)
++])])
+
+ dnl ==========================================================================
+