summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-04-17 13:34:04 +0000
committerJoe McCann <joem@gentoo.org>2005-04-17 13:34:04 +0000
commitecb87506af24178e7dc1edd14bc0c5a93ca931c7 (patch)
tree939ba062a8a1f434b222a57f5fbf54b70754560f /gnome-base/orbit/orbit-2.12.2.ebuild
parentstable on amd64 wrt #89303 (diff)
downloadgentoo-2-ecb87506af24178e7dc1edd14bc0c5a93ca931c7.tar.gz
gentoo-2-ecb87506af24178e7dc1edd14bc0c5a93ca931c7.tar.bz2
gentoo-2-ecb87506af24178e7dc1edd14bc0c5a93ca931c7.zip
bugfix release
(Portage version: 2.0.51.19)
Diffstat (limited to 'gnome-base/orbit/orbit-2.12.2.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.12.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-base/orbit/orbit-2.12.2.ebuild b/gnome-base/orbit/orbit-2.12.2.ebuild
new file mode 100644
index 000000000000..54a3fbda2e76
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.12.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.2.ebuild,v 1.1 2005/04/17 13:34:04 joem Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ssl"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.8.2
+ dev-util/indent
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+USE_DESTDIR="1"
+
+DOCS="AUTHORS ChangeLog README HACKING NEWS TODO MAINTAINERS"