summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2006-03-16 07:51:08 +0000
committerJoe McCann <joem@gentoo.org>2006-03-16 07:51:08 +0000
commitef381d59ca27a1d4f14e56fe4cadac9e43fa14ab (patch)
tree7e7f9a0af12aa6303aac063ed03f9c1c76c18645 /gnome-base/orbit/orbit-2.14.0.ebuild
parentNew upstream version. (diff)
downloadgentoo-2-ef381d59ca27a1d4f14e56fe4cadac9e43fa14ab.tar.gz
gentoo-2-ef381d59ca27a1d4f14e56fe4cadac9e43fa14ab.tar.bz2
gentoo-2-ef381d59ca27a1d4f14e56fe4cadac9e43fa14ab.zip
New release for gnome-2.14
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.0.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-base/orbit/orbit-2.14.0.ebuild b/gnome-base/orbit/orbit-2.14.0.ebuild
new file mode 100644
index 000000000000..923f65019088
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.1 2006/03/16 07:51:07 joem Exp $
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ssl static"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.8.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable static)"
+}