summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-16 21:46:57 +0000
committerMart Raudsepp <leio@gentoo.org>2008-03-16 21:46:57 +0000
commit2c285a9802d0a65028ec6201bd54367e203e3950 (patch)
tree4dad03ddfe2f6aee5208332066f61fba35689e00 /gnome-base/orbit/orbit-2.14.7.ebuild
parentversion bump; rm unnedded patch (diff)
downloadgentoo-2-2c285a9802d0a65028ec6201bd54367e203e3950.tar.gz
gentoo-2-2c285a9802d0a65028ec6201bd54367e203e3950.tar.bz2
gentoo-2-2c285a9802d0a65028ec6201bd54367e203e3950.zip
Remove old. Be compatible with newer glib and in general more future proof in the rest; bug 213434
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.7.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.7.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnome-base/orbit/orbit-2.14.7.ebuild b/gnome-base/orbit/orbit-2.14.7.ebuild
index 328ddccff55d..c05ffa65ab7b 100644
--- a/gnome-base/orbit/orbit-2.14.7.ebuild
+++ b/gnome-base/orbit/orbit-2.14.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.7.ebuild,v 1.10 2007/08/25 14:24:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.7.ebuild,v 1.11 2008/03/16 21:46:57 leio Exp $
inherit gnome2
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+KEYWORDS="arm sh"
IUSE="doc"
RDEPEND=">=dev-libs/glib-2.8
@@ -31,6 +31,17 @@ MAKEOPTS="${MAKEOPTS} -j1"
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+src_unpack() {
+ gnome2_src_unpack
+
+ # Filter out G_DISABLE_DEPRECATED to work with glib-2.16 and be future-proof, bug 213434
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ "${S}/linc2/src/Makefile.am" "${S}/linc2/src/Makefile.in"
+
+ sed -i -e 's:-DG_DISABLE_DEPRECATED::g' \
+ "${S}/configure.in" "${S}/configure"
+}
+
src_compile() {
# We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
# files to be not found by autotools when compiling ORBit. See bug #58540