summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-08 17:04:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-08 17:04:29 +0000
commit2ea12057d011ce445f21dc8d7fbe31c97ed6a3ae (patch)
treeb363c15b841b6ca44bb66f1023d31fc15cf57b45 /gnome-base
parentVersion bump (diff)
downloadgentoo-2-2ea12057d011ce445f21dc8d7fbe31c97ed6a3ae.tar.gz
gentoo-2-2ea12057d011ce445f21dc8d7fbe31c97ed6a3ae.tar.bz2
gentoo-2-2ea12057d011ce445f21dc8d7fbe31c97ed6a3ae.zip
Fix support for cpufreq again, bug #393497.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-applets/ChangeLog6
-rw-r--r--gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild21
2 files changed, 16 insertions, 11 deletions
diff --git a/gnome-base/gnome-applets/ChangeLog b/gnome-base/gnome-applets/ChangeLog
index db1be4ae6995..0569ee0794f7 100644
--- a/gnome-base/gnome-applets/ChangeLog
+++ b/gnome-base/gnome-applets/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/gnome-applets
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/ChangeLog,v 1.373 2013/09/01 17:34:43 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/ChangeLog,v 1.374 2013/09/08 17:04:29 eva Exp $
+
+ 08 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ gnome-applets-3.6.0-r1.ebuild:
+ Fix support for cpufreq again, bug #393497.
01 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
gnome-applets-3.6.0-r1.ebuild:
diff --git a/gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild b/gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild
index ed18eedd2568..df432d4c2faf 100644
--- a/gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild
+++ b/gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild,v 1.3 2013/09/01 17:34:43 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-3.6.0-r1.ebuild,v 1.4 2013/09/08 17:04:29 eva Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2 FDL-1.1 LGPL-2"
SLOT="0"
-IUSE="gnome ipv6 networkmanager policykit"
+IUSE="+cpufreq gnome ipv6 networkmanager policykit"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
# 3.6 is tagged in upstream git, but the tarballs have not been uploaded :/
SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}-unofficial.tar.xz"
@@ -41,6 +41,7 @@ RDEPEND="
=dev-libs/libgweather-3.6*:=
x11-libs/libX11
+ cpufreq? ( sys-power/cpufrequtils )
gnome? (
gnome-base/gnome-settings-daemon
@@ -78,14 +79,14 @@ src_configure() {
# We don't want HAL or battstat.
# mixer applet uses gstreamer, conflicts with the mixer provided by g-s-d
# GNOME 3 has a hard-dependency on pulseaudio, so gstmixer applet is useless
- G2CONF="${G2CONF}
- --without-hal
- --disable-battstat
- --disable-mixer-applet
- $(use_enable ipv6)
- $(use_enable networkmanager)
- $(use_enable policykit polkit)"
- gnome2_src_configure
+ gnome2_src_configure \
+ --without-hal \
+ --disable-battstat \
+ --disable-mixer-applet \
+ $(use_enable ipv6) \
+ $(use_enable networkmanager) \
+ $(use_enable policykit polkit) \
+ $(usex cpufreq "" --disable-cpufreq)
}
src_test() {