summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-14 21:03:34 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-14 21:03:34 +0000
commit4d93b3acf2815b7f62d006237716bd8835f1d408 (patch)
treea3e78cd9b372bc0160656d54dc112d9c7e93933d /gnome-base
parentnew gdm ... (diff)
downloadgentoo-2-4d93b3acf2815b7f62d006237716bd8835f1d408.tar.gz
gentoo-2-4d93b3acf2815b7f62d006237716bd8835f1d408.tar.bz2
gentoo-2-4d93b3acf2815b7f62d006237716bd8835f1d408.zip
updated, lots of bugfixes
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/files/digest-gconf-1.0.51
-rw-r--r--gnome-base/gconf/gconf-1.0.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-base/gconf/files/digest-gconf-1.0.5 b/gnome-base/gconf/files/digest-gconf-1.0.5
new file mode 100644
index 000000000000..fd3997810428
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-1.0.5
@@ -0,0 +1 @@
+MD5 0b2d2c0797c35ec5ae7d3201fc9701b3 GConf-1.0.5.tar.gz
diff --git a/gnome-base/gconf/gconf-1.0.5.ebuild b/gnome-base/gconf/gconf-1.0.5.ebuild
new file mode 100644
index 000000000000..c6e9487deb66
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.5.ebuild,v 1.1 2001/10/14 21:03:34 hallski Exp $
+
+P=GConf-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/GConf/${P}.tar.gz"
+
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=sys-libs/db-3.2.3h
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}