summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-11-06 15:53:06 +0000
committerPacho Ramos <pacho@gentoo.org>2010-11-06 15:53:06 +0000
commitfa3f48cc09c1a4b07d29f07d6c47051467a445a2 (patch)
tree0b5b872e0138f4bf5dec64f4067ccbe6fe12544d /gnome-base
parentVersion Bump (diff)
downloadgentoo-2-fa3f48cc09c1a4b07d29f07d6c47051467a445a2.tar.gz
gentoo-2-fa3f48cc09c1a4b07d29f07d6c47051467a445a2.tar.bz2
gentoo-2-fa3f48cc09c1a4b07d29f07d6c47051467a445a2.zip
Fix vala automagic support, upstream bug #634171
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf/ChangeLog8
-rw-r--r--gnome-base/dconf/dconf-0.5.1-r1.ebuild44
-rw-r--r--gnome-base/dconf/dconf-0.5.1.ebuild29
-rw-r--r--gnome-base/dconf/files/dconf-0.5.1-automagic-vala.patch19
-rw-r--r--gnome-base/dconf/metadata.xml1
5 files changed, 71 insertions, 30 deletions
diff --git a/gnome-base/dconf/ChangeLog b/gnome-base/dconf/ChangeLog
index a723b82ba2ef..8fc74055bad0 100644
--- a/gnome-base/dconf/ChangeLog
+++ b/gnome-base/dconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/dconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.1 2010/10/17 19:32:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.2 2010/11/06 15:53:06 pacho Exp $
+
+*dconf-0.5.1-r1 (06 Nov 2010)
+
+ 06 Nov 2010; Pacho Ramos <pacho@gentoo.org> -dconf-0.5.1.ebuild,
+ +dconf-0.5.1-r1.ebuild, +files/dconf-0.5.1-automagic-vala.patch:
+ Fix vala automagic support, upstream bug #634171
*dconf-0.5.1 (17 Oct 2010)
diff --git a/gnome-base/dconf/dconf-0.5.1-r1.ebuild b/gnome-base/dconf/dconf-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..a398ef41ee9e
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.5.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.5.1-r1.ebuild,v 1.1 2010/11/06 15:53:06 pacho Exp $
+
+EAPI=3
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="http://live.gnome.org/dconf"
+SRC_URI="${SRC_URI} mirror://gentoo/introspection.m4.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection vala"
+
+RDEPEND=">=dev-libs/glib-2.25.16
+ >=dev-libs/libgee-0.5.1
+ >=dev-libs/libxml2-2.7.7
+ x11-libs/gtk+:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ vala? ( >=dev-lang/vala-0.9.5:0.10 )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_enable vala)
+ VALAC=$(type -p valac-0.10)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix vala automagic support, upstream bug #634171
+ epatch "${FILESDIR}/${P}-automagic-vala.patch"
+
+ mv "${WORKDIR}"/introspection.m4 . || die
+ mkdir -p m4 || die
+ AT_M4DIR="." eautoreconf
+}
diff --git a/gnome-base/dconf/dconf-0.5.1.ebuild b/gnome-base/dconf/dconf-0.5.1.ebuild
deleted file mode 100644
index 568da0a2820a..000000000000
--- a/gnome-base/dconf/dconf-0.5.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.5.1.ebuild,v 1.1 2010/10/17 19:32:47 pacho Exp $
-
-EAPI=3
-GCONF_DEBUG="no"
-
-inherit gnome2
-
-DESCRIPTION="Simple low-level configuration system"
-HOMEPAGE="http://live.gnome.org/dconf"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +introspection"
-
-RDEPEND=">=dev-libs/glib-2.25.16
- >=dev-libs/libgee-0.5.1
- >=dev-libs/libxml2-2.7.7
- x11-libs/gtk+:2
- introspection? ( >=dev-libs/gobject-introspection-0.9.3 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-util/gtk-doc-1.15 )"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- $(use_enable introspection)"
-}
diff --git a/gnome-base/dconf/files/dconf-0.5.1-automagic-vala.patch b/gnome-base/dconf/files/dconf-0.5.1-automagic-vala.patch
new file mode 100644
index 000000000000..dcdef5578e9d
--- /dev/null
+++ b/gnome-base/dconf/files/dconf-0.5.1-automagic-vala.patch
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2010-11-06 16:24:36.000000000 +0100
++++ configure.ac 2010-11-06 16:24:19.000000000 +0100
+@@ -12,7 +12,15 @@
+
+ # Check for programs
+ AC_PROG_CC
+-AM_PROG_VALAC([0.9.5])
++
++AC_ARG_ENABLE(vala,
++ AC_HELP_STRING([--disable-vala],
++ [Disable vala support]))
++AM_CONDITIONAL(ENABLE_VALA, test "x$enable_vala" != "xno")
++
++if test "x$enable_vala" != "xno"; then
++ AM_PROG_VALAC([0.9.5])
++fi
+
+ # Introspection
+ GOBJECT_INTROSPECTION_CHECK([0.9.5])
diff --git a/gnome-base/dconf/metadata.xml b/gnome-base/dconf/metadata.xml
index 492a4f76bce6..a81b60978a0c 100644
--- a/gnome-base/dconf/metadata.xml
+++ b/gnome-base/dconf/metadata.xml
@@ -6,5 +6,6 @@
<flag name="introspection">Use
<pkg>dev-libs/gobject-introspection</pkg> for
introspection</flag>
+ <flag name="vala">Add support for <pkg>dev-lang/vala</pkg></flag>
</use>
</pkgmetadata>