summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-01-12 22:34:20 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-01-12 22:34:20 +0000
commit8cea7ddb1e1810a3e5c8afd439a7f1cd671efd6a (patch)
treed1e8464482ba9840d2a3186baa376afd0d468404 /gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild
parentapp-text/poppler provides pdftohtml as well. (diff)
downloadgentoo-2-8cea7ddb1e1810a3e5c8afd439a7f1cd671efd6a.tar.gz
gentoo-2-8cea7ddb1e1810a3e5c8afd439a7f1cd671efd6a.tar.bz2
gentoo-2-8cea7ddb1e1810a3e5c8afd439a7f1cd671efd6a.zip
Moving gnome-extra/libgtkhtml to gnome-extra/gtkhtml
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild')
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild b/gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild
new file mode 100644
index 000000000000..f46fb9bf6758
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-2.6.0.ebuild,v 1.1 2006/01/12 22:34:20 compnerd Exp $
+
+inherit eutils gnome2 versionator
+
+MY_P="lib${P}"
+MY_PN="lib${PN}"
+MY_MAJ_PV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="a Gtk+ based HTML rendering library"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${MY_MAJ_PV}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86"
+IUSE="accessibility"
+
+# FIXME : seems only testapps need gnomevfs
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=dev-libs/libxml2-2.4.16
+ >=gnome-base/gnome-vfs-2
+ accessibility? ( >=gnome-base/gail-1.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+G2CONF="${G2CONF} $(use_enable accessibility)"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO docs/IDEAS"
+MAKEOPTS="${MAKEOPTS} -j1"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ if use alpha; then
+ epatch ${FILESDIR}/${MY_PN}-2.2.0-alpha.patch || die
+ fi
+
+}