summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-22 17:47:14 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-22 17:47:14 +0000
commitc34d888a74fb8dfe0085ce7a85eddb45ab1e4d28 (patch)
treeebf99e6f8870ebeb474cb87c083a55a2129e7fe5 /gnome-extra/gucharmap
parentnew snapshot, compilefix for imagemagick-6.8.4.9 (diff)
downloadgentoo-2-c34d888a74fb8dfe0085ce7a85eddb45ab1e4d28.tar.gz
gentoo-2-c34d888a74fb8dfe0085ce7a85eddb45ab1e4d28.tar.bz2
gentoo-2-c34d888a74fb8dfe0085ce7a85eddb45ab1e4d28.zip
Version bump, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/ChangeLog8
-rw-r--r--gnome-extra/gucharmap/gucharmap-3.8.1.ebuild (renamed from gnome-extra/gucharmap/gucharmap-3.8.0.ebuild)27
2 files changed, 21 insertions, 14 deletions
diff --git a/gnome-extra/gucharmap/ChangeLog b/gnome-extra/gucharmap/ChangeLog
index 147af4c1a9c2..fa3ffde09629 100644
--- a/gnome-extra/gucharmap/ChangeLog
+++ b/gnome-extra/gucharmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gucharmap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/ChangeLog,v 1.202 2013/04/09 16:43:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/ChangeLog,v 1.203 2013/04/22 17:47:14 pacho Exp $
+
+*gucharmap-3.8.1 (22 Apr 2013)
+
+ 22 Apr 2013; Pacho Ramos <pacho@gentoo.org> +gucharmap-3.8.1.ebuild,
+ -gucharmap-3.8.0.ebuild:
+ Version bump, drop old
09 Apr 2013; Agostino Sarubbo <ago@gentoo.org> gucharmap-3.6.1.ebuild:
Stable for sh, wrt bug #458984
diff --git a/gnome-extra/gucharmap/gucharmap-3.8.0.ebuild b/gnome-extra/gucharmap/gucharmap-3.8.1.ebuild
index 10920105e0be..ea505aff1b9d 100644
--- a/gnome-extra/gucharmap/gucharmap-3.8.0.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-3.8.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/gucharmap-3.8.0.ebuild,v 1.1 2013/03/28 17:25:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/gucharmap-3.8.1.ebuild,v 1.1 2013/04/22 17:47:14 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes"
VALA_MIN_API_VERSION="0.16"
VALA_USE_DEPEND="vapigen"
-inherit autotools gnome2 vala
+inherit gnome2 vala
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="http://live.gnome.org/Gucharmap"
@@ -39,22 +39,23 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- G2CONF="${G2CONF}
- --disable-static
- $(use_enable introspection)
- $(use_enable cjk unihan)
- $(use_enable vala)"
- # Do not add ITSTOOL=$(type -P true); yelp-tools is a true required
- # dependency here for some LINGUAS.
-
# prevent file collisions with slot 0
sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
-i configure.ac configure || die "sed configure.ac configure failed"
- eautoreconf
+ # avoid autoreconf
+ sed -e 's/-Wall //g' -i configure || die "sed failed"
+
use vala && vala_src_prepare
gnome2_src_prepare
+}
- # avoid autoreconf
- sed -e 's/-Wall //g' -i configure || die "sed failed"
+src_configure() {
+ # Do not add ITSTOOL=$(type -P true); yelp-tools is a true required
+ # dependency here for some LINGUAS.
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable cjk unihan) \
+ $(use_enable vala)
}