summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 21:58:10 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 21:58:10 +0000
commitcbab244b3f98c54deea8b0bc20153061dcf8a09a (patch)
tree88fbc541a59b2e610a9883762d6f8469a51b5b46 /gnome-extra/hamster-applet
parentAdd ghc 6.12.3 as a core package to dev-haskell/time-1.1.4. (diff)
downloadgentoo-2-cbab244b3f98c54deea8b0bc20153061dcf8a09a.tar.gz
gentoo-2-cbab244b3f98c54deea8b0bc20153061dcf8a09a.tar.bz2
gentoo-2-cbab244b3f98c54deea8b0bc20153061dcf8a09a.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/hamster-applet')
-rw-r--r--gnome-extra/hamster-applet/ChangeLog7
-rw-r--r--gnome-extra/hamster-applet/hamster-applet-2.30.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/gnome-extra/hamster-applet/ChangeLog b/gnome-extra/hamster-applet/ChangeLog
index 8cc281278a56..0b354ffa1290 100644
--- a/gnome-extra/hamster-applet/ChangeLog
+++ b/gnome-extra/hamster-applet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/hamster-applet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/ChangeLog,v 1.22 2010/06/04 20:03:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/ChangeLog,v 1.23 2010/06/13 21:58:10 pacho Exp $
+
+*hamster-applet-2.30.1 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +hamster-applet-2.30.1.ebuild:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org>
hamster-applet-2.28.2.ebuild:
diff --git a/gnome-extra/hamster-applet/hamster-applet-2.30.1.ebuild b/gnome-extra/hamster-applet/hamster-applet-2.30.1.ebuild
new file mode 100644
index 000000000000..a480832289f1
--- /dev/null
+++ b/gnome-extra/hamster-applet/hamster-applet-2.30.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/hamster-applet-2.30.1.ebuild,v 1.1 2010/06/13 21:58:10 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+SCROLLKEEPER_UPDATE="no"
+
+inherit eutils gnome2 python
+
+DESCRIPTION="Time tracking for the masses, in a GNOME applet"
+HOMEPAGE="http://projecthamster.wordpress.com/"
+
+# license on homepage is out-of-date, was changed to GPL-2 on 2008-04-16
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+IUSE="eds libnotify"
+
+RDEPEND=">=dev-lang/python-2.5[sqlite]
+ dev-python/gconf-python
+ dev-python/libgnome-python
+ dev-python/gnome-applets-python
+ dev-python/dbus-python
+ eds? ( dev-python/evolution-python )
+ libnotify? ( dev-python/notify-python )
+ >=dev-python/pygobject-2.14
+ >=dev-python/pygtk-2.12
+ >=x11-libs/gtk+-2.12
+ x11-libs/libXScrnSaver"
+
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/hamster
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/hamster
+}