summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-10 09:17:11 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-10 09:17:11 +0000
commit1073df57acfa63eedefe020cc4dcb6c873141df0 (patch)
tree209a1e738f6f5e687da370a8c74d7c2a4a15f57c /gnome-extra/medusa
parentNLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) (diff)
downloadgentoo-2-1073df57acfa63eedefe020cc4dcb6c873141df0.tar.gz
gentoo-2-1073df57acfa63eedefe020cc4dcb6c873141df0.tar.bz2
gentoo-2-1073df57acfa63eedefe020cc4dcb6c873141df0.zip
NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) and added dependencies to DEPEND
Diffstat (limited to 'gnome-extra/medusa')
-rw-r--r--gnome-extra/medusa/ChangeLog14
-rw-r--r--gnome-extra/medusa/files/digest-medusa-0.5.1-r31
-rw-r--r--gnome-extra/medusa/medusa-0.5.1-r3.ebuild50
3 files changed, 57 insertions, 8 deletions
diff --git a/gnome-extra/medusa/ChangeLog b/gnome-extra/medusa/ChangeLog
index ba5920434df2..816b0aa3fea3 100644
--- a/gnome-extra/medusa/ChangeLog
+++ b/gnome-extra/medusa/ChangeLog
@@ -1,13 +1,11 @@
# ChangeLog for gnome-extra/medusa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/ChangeLog,v 1.2 2002/03/10 09:17:11 blocke Exp $
-*medusa-0.5.1-r2 (1 Feb 2002)
+*medusa-0.5.1-r3 (10 Mar 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> medusa-0.5.1-r3.ebuild :
+
+ - NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
+ - added some missing DEPENDs
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/gnome-extra/medusa/files/digest-medusa-0.5.1-r3 b/gnome-extra/medusa/files/digest-medusa-0.5.1-r3
new file mode 100644
index 000000000000..1934be951799
--- /dev/null
+++ b/gnome-extra/medusa/files/digest-medusa-0.5.1-r3
@@ -0,0 +1 @@
+MD5 26da7d668110d2a053a53ff23f15d0d0 medusa-0.5.1.tar.gz 384482
diff --git a/gnome-extra/medusa/medusa-0.5.1-r3.ebuild b/gnome-extra/medusa/medusa-0.5.1-r3.ebuild
new file mode 100644
index 000000000000..4e552e64c41e
--- /dev/null
+++ b/gnome-extra/medusa/medusa-0.5.1-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/medusa-0.5.1-r3.ebuild,v 1.1 2002/03/10 09:17:11 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Medusa search system for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-vfs-1.0.2-r1
+ nls? ( >=dev-util/intltool-0.11 sys-devel/gettext )
+ dev-libs/libxml
+ gnome-base/gnome-libs"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ CFLAGS="${CFLAGS} -I/usr/include/gnome-1.0"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sharedstatedir=/var/lib \
+ --localstatedir=/var/lib \
+ --enable-prefer-db1 \
+ ${myconf} || die
+
+ # uid_t and gid_t is not #defined, fix
+ mv libmedusa/medusa-file-info-utilities.h \
+ libmedusa/medusa-file-info-utilities.h.orig
+ sed -e 's/uid_t/__uid_t/' \
+ -e 's/gid_t/__gid_t/' \
+ libmedusa/medusa-file-info-utilities.h.orig \
+ > libmedusa/medusa-file-info-utilities.h
+
+ emake medusainitdir=/tmp || die
+}
+
+src_install() {
+ make DESTDIR=${D} medusainitdir=/tmp install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+}
+