summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-09-09 14:34:52 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-09-09 14:34:52 +0000
commitf325b8ac4b9886fe9259c4bc586d66b4a0a49544 (patch)
treeae2d650d84e66a77ed361c30809d1549188861ff /gnome-extra/medusa
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-f325b8ac4b9886fe9259c4bc586d66b4a0a49544.tar.gz
gentoo-2-f325b8ac4b9886fe9259c4bc586d66b4a0a49544.tar.bz2
gentoo-2-f325b8ac4b9886fe9259c4bc586d66b4a0a49544.zip
Restore medusa
Diffstat (limited to 'gnome-extra/medusa')
-rw-r--r--gnome-extra/medusa/ChangeLog23
-rw-r--r--gnome-extra/medusa/Manifest6
-rw-r--r--gnome-extra/medusa/files/digest-medusa-0.5.1-r31
-rw-r--r--gnome-extra/medusa/files/digest-medusa-0.5.1-r41
-rw-r--r--gnome-extra/medusa/medusa-0.5.1-r3.ebuild53
-rw-r--r--gnome-extra/medusa/medusa-0.5.1-r4.ebuild72
-rw-r--r--gnome-extra/medusa/metadata.xml5
7 files changed, 161 insertions, 0 deletions
diff --git a/gnome-extra/medusa/ChangeLog b/gnome-extra/medusa/ChangeLog
new file mode 100644
index 000000000000..1ab3251cb0c4
--- /dev/null
+++ b/gnome-extra/medusa/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for gnome-extra/medusa
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/ChangeLog,v 1.10 2004/09/09 14:34:52 caleb Exp $
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
+ 25 Jul 2002; Spider <spider@gentoo.org>
+ SLOT KEYWORDS and LICENSE added
+
+
+*medusa-0.5.1-r4 (15 Mar 2002)
+
+ 15 Mar 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Fix compile error for libtool-1.4.2.
+
+*medusa-0.5.1-r3 (10 Mar 2002)
+
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> medusa-0.5.1-r3.ebuild :
+
+ - NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
+ - added some missing DEPENDs
+
diff --git a/gnome-extra/medusa/Manifest b/gnome-extra/medusa/Manifest
new file mode 100644
index 000000000000..693bac013c9f
--- /dev/null
+++ b/gnome-extra/medusa/Manifest
@@ -0,0 +1,6 @@
+MD5 12670e300bc602b4855cbc69c500a8e0 medusa-0.5.1-r4.ebuild 1812
+MD5 1c208393a898f10686e54cfc572ac130 ChangeLog 704
+MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 b7a4fd35164275c82ba0c3505c4fde9a medusa-0.5.1-r3.ebuild 1471
+MD5 dba6931a376c50f5e1e44a6dd6f862c9 files/digest-medusa-0.5.1-r3 64
+MD5 dba6931a376c50f5e1e44a6dd6f862c9 files/digest-medusa-0.5.1-r4 64
diff --git a/gnome-extra/medusa/files/digest-medusa-0.5.1-r3 b/gnome-extra/medusa/files/digest-medusa-0.5.1-r3
new file mode 100644
index 000000000000..1934be951799
--- /dev/null
+++ b/gnome-extra/medusa/files/digest-medusa-0.5.1-r3
@@ -0,0 +1 @@
+MD5 26da7d668110d2a053a53ff23f15d0d0 medusa-0.5.1.tar.gz 384482
diff --git a/gnome-extra/medusa/files/digest-medusa-0.5.1-r4 b/gnome-extra/medusa/files/digest-medusa-0.5.1-r4
new file mode 100644
index 000000000000..1934be951799
--- /dev/null
+++ b/gnome-extra/medusa/files/digest-medusa-0.5.1-r4
@@ -0,0 +1 @@
+MD5 26da7d668110d2a053a53ff23f15d0d0 medusa-0.5.1.tar.gz 384482
diff --git a/gnome-extra/medusa/medusa-0.5.1-r3.ebuild b/gnome-extra/medusa/medusa-0.5.1-r3.ebuild
new file mode 100644
index 000000000000..c1c6e477990d
--- /dev/null
+++ b/gnome-extra/medusa/medusa-0.5.1-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/medusa-0.5.1-r3.ebuild,v 1.14 2004/09/09 14:34:52 caleb Exp $
+
+IUSE="nls"
+
+DESCRIPTION="Medusa search system for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+SLOT="0"
+
+
+DEPEND=">=gnome-base/gnome-vfs-1.0.2-r1
+ nls? ( >=dev-util/intltool-0.11 sys-devel/gettext )
+ dev-libs/libxml
+ gnome-base/gnome-libs"
+RDEPEND=$DEPEND
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ CFLAGS="${CFLAGS} -I/usr/include/gnome-1.0"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sharedstatedir=/var/lib \
+ --localstatedir=/var/lib \
+ --enable-prefer-db1 \
+ ${myconf} || die
+
+ # uid_t and gid_t is not #defined, fix
+ mv libmedusa/medusa-file-info-utilities.h \
+ libmedusa/medusa-file-info-utilities.h.orig
+ sed -e 's/uid_t/__uid_t/' \
+ -e 's/gid_t/__gid_t/' \
+ libmedusa/medusa-file-info-utilities.h.orig \
+ > libmedusa/medusa-file-info-utilities.h
+
+ emake medusainitdir=/tmp || die
+}
+
+src_install() {
+ make DESTDIR=${D} medusainitdir=/tmp install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+}
diff --git a/gnome-extra/medusa/medusa-0.5.1-r4.ebuild b/gnome-extra/medusa/medusa-0.5.1-r4.ebuild
new file mode 100644
index 000000000000..2629b4c980f5
--- /dev/null
+++ b/gnome-extra/medusa/medusa-0.5.1-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/medusa-0.5.1-r4.ebuild,v 1.15 2004/09/09 14:34:52 caleb Exp $
+
+IUSE="nls"
+
+DESCRIPTION="Medusa search system for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+SLOT="0"
+
+DEPEND=">=gnome-base/gnome-vfs-1.0.2-r1
+ nls? ( >=dev-util/intltool-0.11 sys-devel/gettext )
+ dev-libs/libxml
+ gnome-base/gnome-libs
+ >=sys-devel/libtool-1.4.2-r1"
+RDEPEND=$DEPEND
+src_unpack() {
+
+ unpack ${A}
+
+ #fix buggy Makefile for use with later versions of libtool
+ cd ${S}/gnome-vfs-module
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:-L$(top_builddir)/libmedusa/.libs:-L$(top_builddir)/libmedusa:' \
+ Makefile.in.orig >Makefile.in
+ cd ${S}
+
+ #update libtool to fix "relink" bug
+ libtoolize --copy --force &>/dev/null
+ aclocal
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ CFLAGS="${CFLAGS} -I/usr/include/gnome-1.0"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sharedstatedir=/var/lib \
+ --localstatedir=/var/lib \
+ --enable-prefer-db1 \
+ ${myconf} || die
+
+ # uid_t and gid_t is not #defined, fix
+ mv libmedusa/medusa-file-info-utilities.h \
+ libmedusa/medusa-file-info-utilities.h.orig
+ sed -e 's/uid_t/__uid_t/' \
+ -e 's/gid_t/__gid_t/' \
+ libmedusa/medusa-file-info-utilities.h.orig \
+ > libmedusa/medusa-file-info-utilities.h
+
+ emake medusainitdir=/tmp -k check || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ medusainitdir=/tmp \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+}
diff --git a/gnome-extra/medusa/metadata.xml b/gnome-extra/medusa/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-extra/medusa/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>