summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-08-29 03:59:47 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-08-29 03:59:47 +0000
commit4dd6bc294cd381795fd96e606b0534b344e5fb98 (patch)
tree44f6d397ec6fd79b1b3365e722cc71104bd49baf /gnome-extra/nautilus-sendto
parentadd pidgin useflag for nautilus-sendto (diff)
downloadgentoo-2-4dd6bc294cd381795fd96e606b0534b344e5fb98.tar.gz
gentoo-2-4dd6bc294cd381795fd96e606b0534b344e5fb98.tar.bz2
gentoo-2-4dd6bc294cd381795fd96e606b0534b344e5fb98.zip
version bump from upstream (bug #190383)
(Portage version: 2.1.3.7)
Diffstat (limited to 'gnome-extra/nautilus-sendto')
-rw-r--r--gnome-extra/nautilus-sendto/ChangeLog9
-rw-r--r--gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.123
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-configure-options.patch218
-rw-r--r--gnome-extra/nautilus-sendto/nautilus-sendto-0.12.ebuild75
4 files changed, 304 insertions, 1 deletions
diff --git a/gnome-extra/nautilus-sendto/ChangeLog b/gnome-extra/nautilus-sendto/ChangeLog
index e5afcd8273af..7eeb746f35b7 100644
--- a/gnome-extra/nautilus-sendto/ChangeLog
+++ b/gnome-extra/nautilus-sendto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/nautilus-sendto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.17 2007/08/02 05:46:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.18 2007/08/29 03:59:47 compnerd Exp $
+
+*nautilus-sendto-0.12 (29 Aug 2007)
+
+ 29 Aug 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/nautilus-sendto-0.12-configure-options.patch,
+ +nautilus-sendto-0.12.ebuild:
+ Version bump from upstream (bug #190383)
02 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org>
nautilus-sendto-0.8-r1.ebuild, nautilus-sendto-0.10.ebuild:
diff --git a/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12 b/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12
new file mode 100644
index 000000000000..a663b2d7bbd9
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.12
@@ -0,0 +1,3 @@
+MD5 9ec9a476be9a1c24ceddcfd76c6b3be2 nautilus-sendto-0.12.tar.bz2 336188
+RMD160 d90730aa1af385240d62d38bbda78ffdb699fe76 nautilus-sendto-0.12.tar.bz2 336188
+SHA256 e91af28d5473997836e85aa5eabb39e53f88fdc7cc535d2b0399afdaee1184ab nautilus-sendto-0.12.tar.bz2 336188
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-configure-options.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-configure-options.patch
new file mode 100644
index 000000000000..e74d1efb8ab5
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.12-configure-options.patch
@@ -0,0 +1,218 @@
+--- configure.in 2007-08-13 08:30:27.000000000 -0700
++++ configure.in.orig 2007-08-28 20:22:36.000000000 -0700
+@@ -63,79 +63,76 @@
+ dnl Libebook support
+ dnl ---------------------------------
+
+-PKG_CHECK_MODULES(NST_EBOOK, libebook-1.2 >= $EBOOK_REQUIRED,
+- [
+- AC_SUBST(NST_EBOOK_CFLAGS)
+- AC_SUBST(NST_EBOOK_LIBS)
+- echo "Using libebook-1.2 !"
+- enable_evolution=yes
+- ],
+- [
+- echo "Building without evolution"
+- enable_evolution=no
+- ]
+-)
++AC_ARG_ENABLE([evolution],
++ AC_HELP_STRING([--enable-evolution], [enable support for evolution]),,
++ [enable_evolution=no])
++
++if test x$enable_evolution = xyes ; then
++ PKG_CHECK_MODULES(NST_EBOOK, [libebook-1.2 >= $EBOOK_REQUIRED])
++
++ AC_SUBST([NST_EBOOK_CFLAGS])
++ AC_SUBST([NST_EBOOK_LIBS])
++fi
+
+ AM_CONDITIONAL(HAVE_EVOLUTION, test "x$enable_evolution" = "xyes")
+
+-dnl Gaim support if it's installed
++dnl Gaim support
+ dnl ---------------------------------
+
++AC_ARG_ENABLE([gaim],
++ AC_HELP_STRING([--enable-gaim], [enable support for gaim]),,
++ [enable_gaim=no])
++
++if test x$enable_gaim = xyes ; then
++ PKG_CHECK_MODULES(GAIM, [gaim >= $GAIM_REQUIRED])
+
+-PKG_CHECK_MODULES(GAIM, gaim >= $GAIM_REQUIRED,
+- [
+- AC_SUBST(GAIM_CFLAGS)
+- AC_SUBST(GAIM_LIBS)
+- GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
+- GAIM_DATADIR=`pkg-config --variable=datadir gaim`
+- AC_SUBST(GAIM_LIBDIR)
+- AC_SUBST(GAIM_DATADIR)
+- enable_gaim=yes
+- ],
+- [
+- echo "Building without gaim"
+- enable_gaim=no
+- ]
+-)
++ AC_SUBST([GAIM_CFLAGS])
++ AC_SUBST([GAIM_LIBS])
++
++ GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
++ GAIM_DATADIR=`pkg-config --variable=datadir gaim`
++
++ AC_SUBST([GAIM_LIBDIR])
++ AC_SUBST([GAIM_DATADIR])
++fi
+
+ AM_CONDITIONAL(HAVE_GAIM, test "x$enable_gaim" = "xyes")
+
+-dnl Pidgin support if it's installed
++dnl Pidgin support
+ dnl ---------------------------------
+
++AC_ARG_ENABLE([pidgin],
++ AC_HELP_STRING([--enable-pidgin], [enable support for pidgin]),,
++ [enable_pidgin=no])
++
++if test x$enable_pidgin = xyes ; then
++ PKG_CHECK_MODULES(PIDGIN, [pidgin >= $PIDGIN_REQUIRED purple >= $PIDGIN_REQUIRED])
+
+-PKG_CHECK_MODULES(PIDGIN, pidgin >= $PIDGIN_REQUIRED purple >= $PIDGIN_REQUIRED,
+- [
+- AC_SUBST(PIDGIN_CFLAGS)
+- AC_SUBST(PIDGIN_LIBS)
+- PIDGIN_LIBDIR=`pkg-config --variable=libdir purple`
+- PIDGIN_DATADIR=`pkg-config --variable=datadir purple`
+- AC_SUBST(PIDGIN_LIBDIR)
+- AC_SUBST(PIDGIN_DATADIR)
+- enable_pidgin=yes
+- ],
+- [
+- echo "Building without pidgin"
+- enable_pidgin=no
+- ]
+-)
++ AC_SUBST([PIDGIN_CFLAGS])
++ AC_SUBST([PIDGIN_LIBS])
++
++ PIDGIN_LIBDIR=`pkg-config --variable=libdir purple`
++ PIDGIN_DATADIR=`pkg-config --variable=datadir purple`
++
++ AC_SUBST([PIDGIN_LIBDIR])
++ AC_SUBST([PIDGIN_DATADIR])
++fi
+
+ AM_CONDITIONAL(HAVE_PIDGIN, test "x$enable_pidgin" = "xyes")
+
+-dnl Bluetooth support if it's installed
++dnl Bluetooth support
+ dnl -----------------------------------
+
+-PKG_CHECK_MODULES(BLUETOOTH, dbus-glib-1 >= $DBUS_REQUIRED,
+- [
+- AC_SUBST(BLUETOOTH_CFLAGS)
+- AC_SUBST(BLUETOOTH_LIBS)
+- enable_bluetooth=yes
+- ],
+- [
+- echo "Building without Bluetooth"
+- enable_bluetooth=no
+- ]
+-)
++AC_ARG_ENABLE([bluetooth],
++ AC_HELP_STRING([--enable-bluetooth], [enable support for bluetooth]),,
++ [enable_bluetooth=no])
++
++if test x$enable_bluetooth = xyes ; then
++ PKG_CHECK_MODULES(BLUETOOTH, [dbus-glib-1 >= $DBUS_REQUIRED])
++
++ AC_SUBST([BLUETOOTH_CFLAGS])
++ AC_SUBST([BLUETOOTH_LIBS])
++fi
+
+ AM_CONDITIONAL(HAVE_BLUETOOTH, test "x$enable_bluetooth" = "xyes")
+
+@@ -147,7 +144,9 @@
+ dnl Balsa support
+ dnl -------------------------------------------------
+
+-enable_balsa=no
++AC_ARG_ENABLE([balsa],
++ AC_HELP_STRING([--enable-balsa], [enable support for balsa]),,
++ [enable_balsa=no])
+ AM_CONDITIONAL(HAVE_BALSA, test "x$enable_balsa" = "xyes")
+ dnl -------------------------------------------------
+
+@@ -155,7 +154,9 @@
+ dnl Sylpheed support
+ dnl -------------------------------------------------
+
+-enable_sylpheed=yes
++AC_ARG_ENABLE([sylpheed],
++ AC_HELP_STRING([--enable-sylpheed], [enable support for sylpheed]),,
++ [enable_sylpheed=no])
+ AM_CONDITIONAL(HAVE_SYLPHEED, test "x$enable_sylpheed" = "xyes")
+ dnl -------------------------------------------------
+
+@@ -163,37 +164,35 @@
+ dnl Thunderbird support
+ dnl -------------------------------------------------
+
+-enable_thunderbird=no
++AC_ARG_ENABLE([thunderbird],
++ AC_HELP_STRING([--enable-thunderbird], [enable support for thunderbird]),,
++ [enable_thunderbird=no])
+ AM_CONDITIONAL(HAVE_THUNDERBIRD, test "x$enable_thunderbird" = "xyes")
+ dnl -------------------------------------------------
+
+ dnl Gajim support
+ dnl -------------------------------------------------
+
+-AC_ARG_WITH(gajim,
+- [AS_HELP_STRING(--with-gajim,[Path to Gajim install prefix])],
+- [GAJIM_PATH="$withval"],[GAJIM_PATH="$prefix"])
+-
+-GAJIM_SHARE_DIR="$GAJIM_PATH"/share/gajim
+-
+-PKG_CHECK_MODULES(DBUS, dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED,
+- [
+- AC_SUBST(DBUS_CFLAGS)
+- AC_SUBST(DBUS_LIBS)
+- if test -f "$GAJIM_SHARE_DIR"/data/pixmaps/gajim.png ;
+- then
+- enable_gajim=yes
+- AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])
+- else
+- echo "Building without Gajim support"
+- enable_gajim=no
+- fi
+- ],
+- [
+- echo "Building without Gajim support"
+- enable_gajim=no
+- ]
+-)
++AC_ARG_ENABLE([gajim],
++ AC_HELP_STRING([--enable-gajim], [enable support for gajim]),,
++ [enable_gajim=no])
++
++if test x$enable_gajim = xyes ; then
++ AC_ARG_WITH(gajim,
++ AC_HELP_STRING([--with-gajim], [Path to Gajim install prefix]),
++ [GAJIM_PATH="$withval"], [GAJIM_PATH="$prefix"])
++
++ GAJIM_SHARE_DIR="$GAJIM_PATH"/share/gajim
++
++ if test -f "$GAJIM_SHARE_DIR"/data/pixmaps/gajim.png ; then
++ enable_gajim=yes
++ AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])
++
++ PKG_CHECK_MODULES(DBUS, [dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED])
++ else
++ enable_gajim=no
++ fi
++fi
+
+ AM_CONDITIONAL(HAVE_GAJIM, test "x$enable_gajim" = "xyes")
+
diff --git a/gnome-extra/nautilus-sendto/nautilus-sendto-0.12.ebuild b/gnome-extra/nautilus-sendto/nautilus-sendto-0.12.ebuild
new file mode 100644
index 000000000000..a6b4f43f4faf
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/nautilus-sendto-0.12.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/nautilus-sendto-0.12.ebuild,v 1.1 2007/08/29 03:59:47 compnerd Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="A nautilus extension for sending files to locations"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="bluetooth eds gajim pidgin sylpheed thunderbird"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/libbonobo-2.13.0
+ >=gnome-base/libbonoboui-2.13.0
+ >=gnome-base/libgnome-2.13.0
+ >=gnome-base/libgnomeui-2.13.0
+ >=gnome-base/nautilus-2.13.3
+ >=gnome-base/gconf-2.13.0
+ >=dev-libs/dbus-glib-0.71
+ bluetooth? ( >=net-wireless/gnome-bluetooth-0.6 )
+ eds? ( >=gnome-extra/evolution-data-server-1.5.3 )
+ gajim? ( net-im/gajim )
+ pidgin? ( >=net-im/pidgin-2.0.0 )
+ sylpheed? ( || (
+ mail-client/sylpheed
+ mail-client/claws-mail
+ mail-client/sylpheed-claws
+ )
+ )
+ thunderbird? ( mail-client/mozilla-thunderbird )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=gnome-base/gnome-common-0.12
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-gaim \
+ $(use_enable bluetooth) \
+ $(use_enable eds evolution) \
+ $(use_enable pidgin) \
+ $(use_enable gajim) \
+ $(use_enable sylpheed) \
+ $(use_enable thunderbird)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Convert autodetection into hard options
+ epatch ${FILESDIR}/${PN}-0.12-configure-options.patch
+
+ # Fix thunderbird support
+ epatch ${FILESDIR}/${PN}-0.8-thunderbird-binaries.patch
+
+ # Oh the joys of autotools
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use pidgin ; then
+ elog "To enable SendTo support in pidgin, you must enable the plugin in pidgin"
+ elog "Check Tools -> Preferences -> Plugins in the pidgin menu."
+ fi
+}