summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-07 08:05:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-07 08:05:18 +0000
commit6c2d91243dce3a117b215dd3c9a3cb92c22c4ac2 (patch)
tree7d17ec3ecf19c0e74ad3fd1c8be726b3e1e0f261 /gnome-extra/sushi
parentVersion bump for gnome-3.4; adds undo support for common operations. (diff)
downloadgentoo-2-6c2d91243dce3a117b215dd3c9a3cb92c22c4ac2.tar.gz
gentoo-2-6c2d91243dce3a117b215dd3c9a3cb92c22c4ac2.tar.bz2
gentoo-2-6c2d91243dce3a117b215dd3c9a3cb92c22c4ac2.zip
Version bump for gnome-3.4.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/ChangeLog7
-rw-r--r--gnome-extra/sushi/sushi-0.4.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/gnome-extra/sushi/ChangeLog b/gnome-extra/sushi/ChangeLog
index 240a07232477..20ea6393d4cd 100644
--- a/gnome-extra/sushi/ChangeLog
+++ b/gnome-extra/sushi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/sushi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/ChangeLog,v 1.3 2012/05/05 06:25:21 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/ChangeLog,v 1.4 2012/05/07 08:05:18 tetromino Exp $
+
+*sushi-0.4.1 (07 May 2012)
+
+ 07 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org> +sushi-0.4.1.ebuild:
+ Version bump for gnome-3.4.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> sushi-0.2.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/gnome-extra/sushi/sushi-0.4.1.ebuild b/gnome-extra/sushi/sushi-0.4.1.ebuild
new file mode 100644
index 000000000000..8cb674f61b89
--- /dev/null
+++ b/gnome-extra/sushi/sushi-0.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/sushi/sushi-0.4.1.ebuild,v 1.1 2012/05/07 08:05:18 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="http://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# libX11 needed for sushi_create_foreign_window()
+COMMON_DEPEND=">=x11-libs/gdk-pixbuf-2.22.1[introspection]
+ >=dev-libs/gjs-0.7.7
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=media-libs/clutter-1.10.0:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.0.0:3[introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:0.10[introspection]
+ media-libs/gst-plugins-base:0.10[introspection]
+ media-libs/clutter-gst:1.0[introspection]
+ media-libs/musicbrainz:3
+ net-libs/webkit-gtk:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ x11-themes/gnome-icon-theme-symbolic
+"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ UNOCONV=$(type -P false)
+ --disable-static"
+ DOCS="AUTHORS NEWS README TODO"
+}