summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-04 06:02:36 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-04 06:02:36 +0000
commitecdcbdc4b7525de725721e0ddb6c5c9e1489b10c (patch)
tree761a6d110b385a077948dbeef2291bce5d48aa2e /gnome-extra/yelp/yelp-3.2.1.ebuild
parentBump to 3.2.1 from the gnome overlay. Drop old. Notable changes: JavaScript a... (diff)
downloadgentoo-2-ecdcbdc4b7525de725721e0ddb6c5c9e1489b10c.tar.gz
gentoo-2-ecdcbdc4b7525de725721e0ddb6c5c9e1489b10c.tar.bz2
gentoo-2-ecdcbdc4b7525de725721e0ddb6c5c9e1489b10c.zip
Bump to 3.2.1 from the gnome overlay. Drop old. Notable changes: bugfixes and stability improvements. Drop alpha, arm, ia64, ppc, ppc64, sparc keywords due to yelp-xsl dependency. Keywording bug will be filed later for all of gnome-3.2.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/yelp/yelp-3.2.1.ebuild')
-rw-r--r--gnome-extra/yelp/yelp-3.2.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/yelp/yelp-3.2.1.ebuild b/gnome-extra/yelp/yelp-3.2.1.ebuild
new file mode 100644
index 000000000000..d8317feee597
--- /dev/null
+++ b/gnome-extra/yelp/yelp-3.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-3.2.1.ebuild,v 1.1 2011/11/04 06:02:36 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+# FIXME: gtk-doc scanner fails assertion in gtk_icon_theme_get_for_screen().
+# How? Why?
+IUSE="" # doc
+
+# yelp-xsl-3.1.1 neded due to commit ee830ed9
+RDEPEND="
+ >=x11-libs/gtk+-2.91.8:3
+ >=dev-libs/glib-2.25.11:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-extra/yelp-xsl-3.1.1
+ >=net-libs/webkit-gtk-1.3.2:3
+ >=app-arch/xz-utils-4.9
+ app-arch/bzip2
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.41.0
+ >=dev-util/pkgconfig-0.9
+ gnome-base/gnome-common"
+# doc? ( >=dev-util/gtk-doc-1.13 )
+# If eautoreconf:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ --enable-bz2
+ --enable-lzma"
+}
+
+src_prepare() {
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ epatch "${FILESDIR}/${PN}-3.0.3-man-compatibility.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}