summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 03:48:29 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 03:48:29 +0000
commit0b80f7de88e59a64836a15a7ba66cbb3d3f33ff3 (patch)
tree25a4249b692a2833021569386a90b2741f9e3bac /gnome-extra
parentVersion bump with various bugfixes. Modernize ebuild. (diff)
downloadgentoo-2-0b80f7de88e59a64836a15a7ba66cbb3d3f33ff3.tar.gz
gentoo-2-0b80f7de88e59a64836a15a7ba66cbb3d3f33ff3.tar.bz2
gentoo-2-0b80f7de88e59a64836a15a7ba66cbb3d3f33ff3.zip
Version bump.
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/ChangeLog10
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.6.3.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/gnome-extra/evolution-ews/ChangeLog b/gnome-extra/evolution-ews/ChangeLog
index c3878ad23067..e5228c0319ed 100644
--- a/gnome-extra/evolution-ews/ChangeLog
+++ b/gnome-extra/evolution-ews/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-ews
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-ews/ChangeLog,v 1.5 2012/12/24 04:41:51 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-ews/ChangeLog,v 1.6 2013/01/22 03:48:29 tetromino Exp $
+
+*evolution-ews-3.6.3 (22 Jan 2013)
+
+ 22 Jan 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +evolution-ews-3.6.3.ebuild:
+ Version bump.
24 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
evolution-ews-3.4.4.ebuild, evolution-ews-3.6.1.ebuild:
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.6.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.6.3.ebuild
new file mode 100644
index 000000000000..95de433f9f17
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.6.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-ews/evolution-ews-3.6.3.ebuild,v 1.1 2013/01/22 03:48:29 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit db-use flag-o-matic gnome2 versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kerberos"
+
+RDEPEND="
+ dev-db/sqlite:3=
+ dev-libs/libical:=
+ >=mail-client/evolution-${PV}:2.0[kerberos?]
+ >=gnome-extra/evolution-data-server-${PV}:=[kerberos?]
+ =gnome-extra/evolution-data-server-${MY_MAJORV}*
+ >=dev-libs/glib-2.28:2
+ >=dev-libs/libxml2-2
+ >=net-libs/libsoup-2.30:2.4
+ >=x11-libs/gtk+-3:3
+ kerberos? ( virtual/krb5:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+# Requires connection to an Exchange server
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure $(use_with kerberos krb5)
+}