summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-15 20:53:35 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-15 20:53:35 +0000
commit7f08b70854e2c97a4233994cf1515dba13c9c94c (patch)
tree2e0ff402ef378f48de9c614c8ac4eed6cf39e686 /gnome-extra
parentAdd missing webkit useflags. Don't run eqmake4 when qt4 is disabled. Bug #457744 (diff)
downloadgentoo-2-7f08b70854e2c97a4233994cf1515dba13c9c94c.tar.gz
gentoo-2-7f08b70854e2c97a4233994cf1515dba13c9c94c.tar.bz2
gentoo-2-7f08b70854e2c97a4233994cf1515dba13c9c94c.zip
Don't show elog messages always (#457596)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nautilus-dropbox/ChangeLog7
-rw-r--r--gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild30
2 files changed, 20 insertions, 17 deletions
diff --git a/gnome-extra/nautilus-dropbox/ChangeLog b/gnome-extra/nautilus-dropbox/ChangeLog
index 7f3e94b48897..f8d4731c942a 100644
--- a/gnome-extra/nautilus-dropbox/ChangeLog
+++ b/gnome-extra/nautilus-dropbox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-extra/nautilus-dropbox
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-dropbox/ChangeLog,v 1.17 2012/08/23 03:16:47 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-dropbox/ChangeLog,v 1.18 2013/02/15 20:53:35 pacho Exp $
+
+ 15 Feb 2013; Pacho Ramos <pacho@gentoo.org> nautilus-dropbox-1.4.0.ebuild:
+ Don't show elog messages always (#457596)
23 Aug 2012; Christoph Junghans <ottxor@gentoo.org>
nautilus-dropbox-1.4.0.ebuild:
diff --git a/gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild b/gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild
index 0e31cae13299..0ff8efc5f144 100644
--- a/gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild
+++ b/gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild,v 1.3 2012/08/23 03:16:47 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-dropbox/nautilus-dropbox-1.4.0.ebuild,v 1.4 2013/02/15 20:53:35 pacho Exp $
-EAPI="3"
+EAPI="5"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="2"
-inherit autotools eutils python linux-info gnome2 user
+
+inherit autotools eutils python linux-info gnome2 readme.gentoo user
DESCRIPTION="Store, Sync and Share Files Online"
HOMEPAGE="http://www.dropbox.com/"
@@ -27,9 +29,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
dev-python/docutils"
-DOCS="AUTHORS ChangeLog NEWS README"
-G2CONF="${G2CONF} $(use_enable debug) --disable-static"
-
CONFIG_CHECK="~INOTIFY_USER"
pkg_setup () {
@@ -37,9 +36,15 @@ pkg_setup () {
enewgroup dropbox
python_set_active_version 2
python_pkg_setup
+
+ DOC_CONTENTS="Add any users who wish to have access to the dropbox nautilus
+ plugin to the group 'dropbox'. You need to setup a drobox account
+ before using this plugin. Visit ${HOMEPAGE} for more information."
}
src_prepare() {
+ G2CONF="${G2CONF} $(use_enable debug) --disable-static"
+
gnome2_src_prepare
python_convert_shebangs 2 dropbox.in
@@ -61,18 +66,13 @@ src_install () {
# Strip $EPREFIX from $extensiondir as fowners/fperms act on $ED not $D
extensiondir="${extensiondir#${EPREFIX}}"
- find "${ED}" -name '*.la' -exec rm -f {} + || die
-
use prefix || fowners root:dropbox "${extensiondir}"/libnautilus-dropbox.so
fperms o-rwx "${extensiondir}"/libnautilus-dropbox.so
+
+ readme.gentoo_create_doc
}
pkg_postinst () {
gnome2_pkg_postinst
-
- elog
- elog "Add any users who wish to have access to the dropbox nautilus"
- elog "plugin to the group 'dropbox'. You need to setup a drobox account"
- elog "before using this plugin. Visit ${HOMEPAGE} for more information."
- elog
+ readme.gentoo_print_elog
}