summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-12 18:12:17 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-12 18:12:17 +0000
commit9c37c0936e31ee6014045ddc0c3380777addda03 (patch)
treee127f3840f7cb89360819ace4c5a65de202b4579 /gnome-extra
parentRevision bump, add patch for CVE-2010-2536, and small cleanup: EAPI3, merge w... (diff)
downloadgentoo-2-9c37c0936e31ee6014045ddc0c3380777addda03.tar.gz
gentoo-2-9c37c0936e31ee6014045ddc0c3380777addda03.tar.bz2
gentoo-2-9c37c0936e31ee6014045ddc0c3380777addda03.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/at-spi/ChangeLog10
-rw-r--r--gnome-extra/at-spi/at-spi-1.32.0.ebuild74
2 files changed, 83 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index f2600cad52e0..89a1a641d34f 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.210 2010/10/07 23:40:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.211 2010/10/12 18:12:17 pacho Exp $
+
+*at-spi-1.32.0 (12 Oct 2010)
+
+ 12 Oct 2010; Pacho Ramos <pacho@gentoo.org> +at-spi-1.32.0.ebuild:
+ Version bump for Gnome 2.32: bugfixes and updates, make AT-SPI/CORBA the
+ default and relocate AT-SPI/D-Bus. This also solves bugs #323701 (since
+ Gnome 2.32 clients are ported for relocation) and #324175 (by Arfrever
+ Frehtes Taifersar Arahesis, including improved python support).
07 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> at-spi-1.30.1.ebuild:
ppc64 stable wrt #324077
diff --git a/gnome-extra/at-spi/at-spi-1.32.0.ebuild b/gnome-extra/at-spi/at-spi-1.32.0.ebuild
new file mode 100644
index 000000000000..84e77f3665e6
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.32.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.32.0.ebuild,v 1.1 2010/10/12 18:12:17 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+
+inherit gnome2 python
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.29.2
+ >=x11-libs/gtk+-2.19.7
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+# needs a live properly configured environment. Not really suited to
+# an ebuild restricted environment
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-sm
+ --disable-xevie"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ python_set_active_version 2
+}
+
+src_prepare () {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup pyatspi
+}