summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-02 21:45:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-02 21:45:21 +0000
commit9f0a1f0bb740b7320c43fb7de8d758d6f6734b77 (patch)
treeed0960bf01a99bc624792f967e2b0f8737456b07 /gnome-extra
parentbump to 2.22.3. Bug fixes and translation update. (diff)
downloadgentoo-2-9f0a1f0bb740b7320c43fb7de8d758d6f6734b77.tar.gz
gentoo-2-9f0a1f0bb740b7320c43fb7de8d758d6f6734b77.tar.bz2
gentoo-2-9f0a1f0bb740b7320c43fb7de8d758d6f6734b77.zip
bump to 2.22.3. Bug fixes and translation updates.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/deskbar-applet/ChangeLog8
-rw-r--r--gnome-extra/deskbar-applet/deskbar-applet-2.22.3.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/gnome-extra/deskbar-applet/ChangeLog b/gnome-extra/deskbar-applet/ChangeLog
index 67c41c5b43a1..4e5a52b3c808 100644
--- a/gnome-extra/deskbar-applet/ChangeLog
+++ b/gnome-extra/deskbar-applet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/deskbar-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.86 2008/06/29 20:41:36 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.87 2008/07/02 21:45:21 eva Exp $
+
+*deskbar-applet-2.22.3 (02 Jul 2008)
+
+ 02 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +deskbar-applet-2.22.3.ebuild:
+ bump to 2.22.3. Bug fixes and translation updates.
29 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
-files/deskbar-applet-2.15.3-multilib.patch, deskbar-applet-2.20.3.ebuild,
diff --git a/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.ebuild b/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.ebuild
new file mode 100644
index 000000000000..10f9ed7cecc6
--- /dev/null
+++ b/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.ebuild,v 1.1 2008/07/02 21:45:21 eva Exp $
+
+inherit gnome2 eutils autotools python
+
+DESCRIPTION="An Omnipresent Versatile Search Interface"
+HOMEPAGE="http://raphael.slinckx.net/deskbar/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="eds spell"
+
+# TODO: check if gnome-doc-utils doesn't imply scrollkeeper
+
+RDEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.10
+ >=dev-python/pygtk-2.10
+ >=dev-python/gnome-python-2.10
+ >=gnome-base/gnome-desktop-2.10
+ >=dev-python/dbus-python-0.80.2
+ >=dev-python/gnome-python-desktop-2.14.0
+ >=gnome-base/gconf-2
+ eds? ( >=gnome-extra/evolution-data-server-1.7.92 )
+ spell? ( >=gnome-extra/gnome-utils-2.16.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=sys-devel/autoconf-2.60
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable eds evolution) --exec-prefix=/usr --disable-scrollkeeper"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix installing libs into pythondir
+ epatch "${FILESDIR}"/${PN}-2.19.5-multilib.patch
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/deskbar
+ python_mod_optimize /usr/$(get_libdir)/deskbar-applet/modules-2.20-compatible
+
+ ebeep 5
+ ewarn "The dictionary plugin in deskbar-applet uses the dictionary from "
+ ewarn "gnome-extra/gnome-utils. If it is not present, the dictionary "
+ ewarn "plugin will fail silently."
+ epause 5
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/deskbar
+ python_mod_cleanup /usr/$(get_libdir)/deskbar-applet/modules-2.20-compatible
+}