summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-09-17 22:05:43 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-09-17 22:05:43 +0000
commitbb429a9f9d3170a9355bdee54c2dd43d0af6d227 (patch)
treeb5f1a30e0ab4b28ce4dde94ec4a1e6db9c36e827 /gnome-extra
parentversion bump. new chan_capi-cm replaces old chan_capi and is called chan_capi... (diff)
downloadgentoo-2-bb429a9f9d3170a9355bdee54c2dd43d0af6d227.tar.gz
gentoo-2-bb429a9f9d3170a9355bdee54c2dd43d0af6d227.tar.bz2
gentoo-2-bb429a9f9d3170a9355bdee54c2dd43d0af6d227.zip
built_with_us fix from Ed Catmur <ed@catmur.co.uk> bug #147738
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild b/gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild
index 9b8c037648e8..fbbbc31dcd2a 100644
--- a/gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild
+++ b/gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild,v 1.2 2006/09/05 16:36:23 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hal-device-manager/hal-device-manager-0.5-r1.ebuild,v 1.3 2006/09/17 22:05:43 cardoe Exp $
inherit eutils
@@ -14,21 +14,22 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND=">=sys-apps/hal-${PV}-r1
- >=dev-python/gnome-python-2.0.0-r1"
+ >=sys-apps/dbus-0.60
+ >=dev-python/gnome-python-2.0.0-r1"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig"
S=${WORKDIR}
pkg_setup() {
- if ! built_with_use ">=sys-apps/hal-${PV}-r1" 'python' ; then
- eerror 'Please rebuild hal with the python useflag before installing'
+ if ! built_with_use ">=sys-apps/dbus-0.60" 'python' ; then
+ eerror 'Please rebuild dbus with the python useflag before installing'
eerror 'this package.'
echo
- eerror "echo 'sys-apps/hal python' >> /etc/portage/package.use"
- eerror 'emerge hal'
+ eerror "echo 'sys-apps/dbus python' >> /etc/portage/package.use"
+ eerror 'emerge dbus'
- die "hal python bindings unavailable"
+ die "dbus python bindings unavailable"
fi
}