summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 14:46:11 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 14:46:11 +0000
commitf5e03332475c07034e31c6529d9c723b24241e65 (patch)
tree75a5d97bfe99f8bb52174c25517bfcbf9edf3c57 /gnome-extra
parentVersion bump to fix bug #211123. (diff)
downloadgentoo-2-f5e03332475c07034e31c6529d9c723b24241e65.tar.gz
gentoo-2-f5e03332475c07034e31c6529d9c723b24241e65.tar.bz2
gentoo-2-f5e03332475c07034e31c6529d9c723b24241e65.zip
bump to 2.3.0, change RDEPEND to DEPEND and vice-versa. Add libnotify USE flag
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/music-applet/ChangeLog8
-rw-r--r--gnome-extra/music-applet/music-applet-2.3.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/gnome-extra/music-applet/ChangeLog b/gnome-extra/music-applet/ChangeLog
index 51c4fb2688da..30913e91e39d 100644
--- a/gnome-extra/music-applet/ChangeLog
+++ b/gnome-extra/music-applet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/music-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.10 2008/02/24 11:58:44 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.11 2008/02/24 14:46:11 eva Exp $
+
+*music-applet-2.3.0 (24 Feb 2008)
+
+ 24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +music-applet-2.3.0.ebuild:
+ bump to 2.3.0, change RDEPEND to DEPEND and vice-versa. Add libnotify USE flag
24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
music-applet-2.2.1.ebuild, metadata.xml:
diff --git a/gnome-extra/music-applet/music-applet-2.3.0.ebuild b/gnome-extra/music-applet/music-applet-2.3.0.ebuild
new file mode 100644
index 000000000000..df4529636d64
--- /dev/null
+++ b/gnome-extra/music-applet/music-applet-2.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/music-applet-2.3.0.ebuild,v 1.1 2008/02/24 14:46:11 eva Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://www.kuliniewicz.org/music-applet"
+SRC_URI="http://www.kuliniewicz.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-python/gnome-python-desktop-2.14
+ >=dev-python/numeric-24.2
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ >=dev-python/pygtk-2.6
+ libnotify? ( dev-python/notify-python )"
+DEPEND="dev-util/pkgconfig
+ dev-util/intltool"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/musicapplet
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/musicapplet
+}