summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-25 17:05:13 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-25 17:05:13 +0000
commit040bbcfb25ab680de0500cf2562837ff131709bb (patch)
tree099b255243d748867fd42d117a3575891c68694e /gnome-office
parent*** empty log message *** (diff)
downloadgentoo-2-040bbcfb25ab680de0500cf2562837ff131709bb.tar.gz
gentoo-2-040bbcfb25ab680de0500cf2562837ff131709bb.tar.bz2
gentoo-2-040bbcfb25ab680de0500cf2562837ff131709bb.zip
*** empty log message ***
Diffstat (limited to 'gnome-office')
-rw-r--r--gnome-office/dia/dia-0.86-r1.ebuild8
-rw-r--r--gnome-office/gnome-pim/files/digest-gnome-pim-1.2.0-r11
-rw-r--r--gnome-office/gnumeric/gnumeric-0.59a.ebuild12
3 files changed, 14 insertions, 7 deletions
diff --git a/gnome-office/dia/dia-0.86-r1.ebuild b/gnome-office/dia/dia-0.86-r1.ebuild
index 5b7b7dddb80a..c3371894bad5 100644
--- a/gnome-office/dia/dia-0.86-r1.ebuild
+++ b/gnome-office/dia/dia-0.86-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-office/dia/dia-0.86-r1.ebuild,v 1.3 2000/11/25 16:44:14 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/dia/dia-0.86-r1.ebuild,v 1.4 2000/11/25 17:05:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -17,10 +17,10 @@ src_compile() {
cd ${S}
local myconf
- if [ "`use bonobo`" ]
- then
+# if [ "`use bonobo`" ]
+# then
# myconf="--enable-bonobo"
- fi
+# fi
try ./configure --host=${CHOST} --prefix=/opt/gnome \
--enable-gnome --enable-gnome-print ${myconf}
# bonobo support does not work yet
diff --git a/gnome-office/gnome-pim/files/digest-gnome-pim-1.2.0-r1 b/gnome-office/gnome-pim/files/digest-gnome-pim-1.2.0-r1
new file mode 100644
index 000000000000..f1809eaa3611
--- /dev/null
+++ b/gnome-office/gnome-pim/files/digest-gnome-pim-1.2.0-r1
@@ -0,0 +1 @@
+MD5 d0af4da54851fa996b59d4f738ff2920 gnome-pim-1.2.0.tar.gz
diff --git a/gnome-office/gnumeric/gnumeric-0.59a.ebuild b/gnome-office/gnumeric/gnumeric-0.59a.ebuild
index ebba0974eb6d..27bdd0beabf4 100644
--- a/gnome-office/gnumeric/gnumeric-0.59a.ebuild
+++ b/gnome-office/gnumeric/gnumeric-0.59a.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.59a.ebuild,v 1.1 2000/11/25 13:04:23 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.59a.ebuild,v 1.2 2000/11/25 17:05:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -16,12 +16,18 @@ DEPEND=">=sys-devel/perl-5
>=gnome-base/libunicode-0.4
>=gnome-base/gal-0.2
>=gnome-libs/gb-0.0.15
- >=gnome-libs/libole2-0.1.7"
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28 )"
src_compile() {
cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-bonobo --with-gb
+ ${myconf} --with-gb
cd plugins/perl
cp Makefile Makefile.orig
# sed -e "s:perl Makefile\.PL:perl Makefile\.PL $PERLINSTALL:" \