summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-09-25 21:17:33 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-09-25 21:17:33 +0000
commit3bace45f025615fac6587c63b70f7b7518b9cc6e (patch)
treeee53b3e8e5ff31d0f1d9f5edf3f324b6b68eb037 /gnustep-apps/mylibrary
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-3bace45f025615fac6587c63b70f7b7518b9cc6e.tar.gz
gentoo-2-3bace45f025615fac6587c63b70f7b7518b9cc6e.tar.bz2
gentoo-2-3bace45f025615fac6587c63b70f7b7518b9cc6e.zip
New package; key'd ~x86.
Diffstat (limited to 'gnustep-apps/mylibrary')
-rw-r--r--gnustep-apps/mylibrary/ChangeLog10
-rw-r--r--gnustep-apps/mylibrary/Manifest2
-rw-r--r--gnustep-apps/mylibrary/files/digest-mylibrary-0.4.5g1
-rw-r--r--gnustep-apps/mylibrary/metadata.xml17
-rw-r--r--gnustep-apps/mylibrary/mylibrary-0.4.5g.ebuild31
5 files changed, 61 insertions, 0 deletions
diff --git a/gnustep-apps/mylibrary/ChangeLog b/gnustep-apps/mylibrary/ChangeLog
new file mode 100644
index 000000000000..70ddc469eeb0
--- /dev/null
+++ b/gnustep-apps/mylibrary/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnustep-apps/mylibrary
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/mylibrary/ChangeLog,v 1.1 2004/09/25 21:17:33 fafhrd Exp $
+
+*mylibrary-0.4.5g (25 Sep 2004)
+
+ 25 Sep 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +mylibrary-0.4.5g.ebuild:
+ New package; key'd for ~x86.
+
diff --git a/gnustep-apps/mylibrary/Manifest b/gnustep-apps/mylibrary/Manifest
new file mode 100644
index 000000000000..5687b7d45461
--- /dev/null
+++ b/gnustep-apps/mylibrary/Manifest
@@ -0,0 +1,2 @@
+MD5 956a5b163ee20158024cc98639cf0ffa mylibrary-0.4.5g.ebuild 840
+MD5 69e7780507872ff90ffae36a37ec8d6f files/digest-mylibrary-0.4.5g 68
diff --git a/gnustep-apps/mylibrary/files/digest-mylibrary-0.4.5g b/gnustep-apps/mylibrary/files/digest-mylibrary-0.4.5g
new file mode 100644
index 000000000000..9267f763fb1e
--- /dev/null
+++ b/gnustep-apps/mylibrary/files/digest-mylibrary-0.4.5g
@@ -0,0 +1 @@
+MD5 9579546c7b5fe798650a7d8923316402 MyLibrary-0.4.5g.tar.gz 195839
diff --git a/gnustep-apps/mylibrary/metadata.xml b/gnustep-apps/mylibrary/metadata.xml
new file mode 100644
index 000000000000..39b49bf7a684
--- /dev/null
+++ b/gnustep-apps/mylibrary/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+MyLibrary is a combination of wiki-style notes and file collection.
+
+Features:
+
+1. Server-less wiki-like notes.
+2. Simple tags to render note (&lt;b&gt;>,&lt;&gt;i>,&lt;link&gt;...).
+3. Drag and drop to add files and links.
+4. Search on file attributes and meta-file in the library.
+5. Smart folder to collect notes by criterions.
+6. Content search by namazu
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/mylibrary/mylibrary-0.4.5g.ebuild b/gnustep-apps/mylibrary/mylibrary-0.4.5g.ebuild
new file mode 100644
index 000000000000..bf3612501e81
--- /dev/null
+++ b/gnustep-apps/mylibrary/mylibrary-0.4.5g.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/mylibrary/mylibrary-0.4.5g.ebuild,v 1.1 2004/09/25 21:17:33 fafhrd Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/ML
+
+DESCRIPTION="MyLibrary is a combination of wiki-style notes and file collection."
+HOMEPAGE="http://www.people.virginia.edu/~yc2w/MyLibrary/"
+SRC_URI="http://www.people.virginia.edu/~yc2w/MyLibrary/${P/myl/MyL}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="${IUSE} doc"
+DEPEND="${GS_DEPEND}"
+RDEPEND="${GS_RDEPEND}"
+
+src_install() {
+ egnustep_env
+ egnustep_install || die
+ if use doc
+ then
+ mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/User/MyLibrary
+ cp Documentation/*.png ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/User/MyLibrary
+ cp Documentation/*.html ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/User/MyLibrary
+ fi
+ egnustep_package_config
+}
+