summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-08-19 19:53:05 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-08-19 19:53:05 +0000
commitfc9e586b86a6b0f0e96c5b108db4421d364152d0 (patch)
treec93bae98bb248eca40cd8886b73702d45f29b7c8 /gnustep-apps
parentIf errors are fatal, some software can segfault. (diff)
downloadgentoo-2-fc9e586b86a6b0f0e96c5b108db4421d364152d0.tar.gz
gentoo-2-fc9e586b86a6b0f0e96c5b108db4421d364152d0.tar.bz2
gentoo-2-fc9e586b86a6b0f0e96c5b108db4421d364152d0.zip
Version bump, improvements to the features added in the 0.9.0 release
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/price/ChangeLog7
-rw-r--r--gnustep-apps/price/price-1.0.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/gnustep-apps/price/ChangeLog b/gnustep-apps/price/ChangeLog
index 304237b10164..f59007dc9d9d 100644
--- a/gnustep-apps/price/ChangeLog
+++ b/gnustep-apps/price/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-apps/price
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/ChangeLog,v 1.20 2010/01/05 10:52:52 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/ChangeLog,v 1.21 2010/08/19 19:53:05 voyageur Exp $
+
+*price-1.0.0 (19 Aug 2010)
+
+ 19 Aug 2010; Bernard Cafarelli <voyageur@gentoo.org> +price-1.0.0.ebuild:
+ Version bump, improvements to the features added in the 0.9.0 release
*price-0.9.1 (05 Jan 2010)
diff --git a/gnustep-apps/price/price-1.0.0.ebuild b/gnustep-apps/price/price-1.0.0.ebuild
new file mode 100644
index 000000000000..3fc87b51bddc
--- /dev/null
+++ b/gnustep-apps/price/price-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/price-1.0.0.ebuild,v 1.1 2010/08/19 19:53:05 voyageur Exp $
+
+EAPI=2
+inherit gnustep-2
+
+MY_P=PRICE-${PV}
+DESCRIPTION="Precision Raster Image Convolution Engine"
+HOMEPAGE="http://price.sourceforge.net/"
+SRC_URI="mirror://sourceforge/price/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=gnustep-base/gnustep-gui-0.13.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Mixmatching #include and #import on limits.h leads to bug #278160
+ sed -i -e 's/#import <limits.h>/#include <limits.h>/' *.m || die "sed failed"
+}