summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2005-06-06 05:00:44 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2005-06-06 05:00:44 +0000
commitf3f762fb242dde1d2ae2169da41dd27373a51ddf (patch)
tree3fedec74f383ed936828ac71e4d77c9efa8c70f1 /gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild
parentMinor DEPEND changes for GNUstep eclass (diff)
downloadgentoo-2-f3f762fb242dde1d2ae2169da41dd27373a51ddf.tar.gz
gentoo-2-f3f762fb242dde1d2ae2169da41dd27373a51ddf.tar.bz2
gentoo-2-f3f762fb242dde1d2ae2169da41dd27373a51ddf.zip
Stabilizations and bumps for core gnustep ebuilds.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild')
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild
new file mode 100644
index 000000000000..0c7d5dbca07c
--- /dev/null
+++ b/gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/gnustep-back-art-0.9.6.ebuild,v 1.1 2005/06/06 05:00:12 fafhrd Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~ppc ~x86 ~amd64 ~sparc ~alpha"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+PROVIDE="virtual/gnustep-back"
+
+IUSE="${IUSE} opengl xim doc"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ ~gnustep-base/gnustep-make-1.10.0
+ ~gnustep-base/gnustep-base-1.10.3
+ ~gnustep-base/gnustep-gui-0.9.5
+ virtual/xft
+ ~media-libs/freetype-2.1.9
+ opengl? ( virtual/opengl virtual/glu )
+ gnustep-libs/artresources
+ >=gnustep-base/mknfonts-0.5
+ >=media-libs/libart_lgpl-2.3"
+RDEPEND="${DEPEND}
+ ${DEBUG_DEPEND}
+ ${DOC_RDEPEND}"
+
+egnustep_install_domain "System"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/font-make-fix.patch-0.9.5
+}
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=art --with-name=art"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}
+
+src_install() {
+ gnustep_src_install
+ cd ${S}
+ egnustep_env
+ mkdir -p ${D}/System/Library/Fonts
+ cp -a Fonts/Helvetica.nfont ${D}/${GNUSTEP_SYSTEM_ROOT}/Library/Fonts
+}
+