summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-06-16 09:57:19 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-06-16 09:57:19 +0000
commit84aa6f50078167b27a8b5cff72f2bb2e8ba110db (patch)
tree27ffbe68a7543048804a6aff3ab6cc8de02c242f /gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild
parentNew stable branch, remove unstable version (diff)
downloadgentoo-2-84aa6f50078167b27a8b5cff72f2bb2e8ba110db.tar.gz
gentoo-2-84aa6f50078167b27a8b5cff72f2bb2e8ba110db.tar.bz2
gentoo-2-84aa6f50078167b27a8b5cff72f2bb2e8ba110db.zip
New stable branch, remove unstable version
(Portage version: 2.1.5.5)
Diffstat (limited to 'gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild')
-rw-r--r--gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild
new file mode 100644
index 000000000000..20102c6db7ea
--- /dev/null
+++ b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.14.0.ebuild,v 1.1 2008/06/16 09:57:19 voyageur Exp $
+
+inherit gnustep-base
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="Cairo back-end component for the GNUstep GUI Library."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="opengl xim glitz"
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ ~gnustep-base/gnustep-gui-${PV}
+ opengl? ( virtual/opengl virtual/glu )
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+
+ >=media-libs/freetype-2.1.9
+ >=x11-libs/cairo-1.2.0
+ !gnustep-base/gnustep-back-art
+ !gnustep-base/gnustep-back-xlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ gnustep-base_pkg_setup
+
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "x11-libs/cairo must be compiled with the X USE flag enabled"
+ die "x11-libs/cairo rebuild needed"
+ fi
+}
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf $(use_enable xim)"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=cairo"
+ # Seems broken for now
+ #myconf="$myconf $(use_enable glitz)"
+
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}