summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-11-24 10:54:09 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-11-24 10:54:09 +0000
commit596987cd71a1d9b8349e61362e833e07463486d1 (patch)
tree53ee57715cf1edd79f3556633f0a828ff98fd3c7 /gnustep-base
parentFix compilation against glbc-2.1.4 (changed declaration of type for __malloc_... (diff)
downloadgentoo-2-596987cd71a1d9b8349e61362e833e07463486d1.tar.gz
gentoo-2-596987cd71a1d9b8349e61362e833e07463486d1.tar.bz2
gentoo-2-596987cd71a1d9b8349e61362e833e07463486d1.zip
Version bump
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog8
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.6.ebuild (renamed from gnustep-base/libobjc2/libobjc2-1.5.ebuild)9
2 files changed, 12 insertions, 5 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index 312214c290f0..cd9cb7961bdf 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/libobjc2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.6 2011/08/05 11:47:58 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.7 2011/11/24 10:54:08 voyageur Exp $
+
+*libobjc2-1.6 (24 Nov 2011)
+
+ 24 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org> -libobjc2-1.5.ebuild,
+ +libobjc2-1.6.ebuild:
+ Version bump
*libobjc2-1.5 (05 Aug 2011)
diff --git a/gnustep-base/libobjc2/libobjc2-1.5.ebuild b/gnustep-base/libobjc2/libobjc2-1.6.ebuild
index 34b3d4295827..e88e4daa1c58 100644
--- a/gnustep-base/libobjc2/libobjc2-1.5.ebuild
+++ b/gnustep-base/libobjc2/libobjc2-1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.5.ebuild,v 1.1 2011/08/05 11:47:58 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.6.ebuild,v 1.1 2011/11/24 10:54:08 voyageur Exp $
-EAPI=3
+EAPI=4
inherit multilib
# We need gnustep-make, but gnustep-make can depend on libobjc
@@ -37,12 +37,13 @@ src_configure() {
}
src_compile() {
- emake GNUSTEP_MAKEFILES="${GSMAKE_S}" || die "compilation failed"
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" messages=yes
}
src_install() {
emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
- DESTDIR="${D}" install || die "install has failed"
+ messages=yes \
+ DESTDIR="${D}" install
}