summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-22 12:54:26 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-22 12:54:26 +0000
commita1563af54def9b998cbcd6aed4af3fe52986e4f1 (patch)
treeaf975b1991498998311e52ea3ccdd51332a3252e /gnustep-base
parentversion bump: Bugfix and translation update release (diff)
downloadgentoo-2-a1563af54def9b998cbcd6aed4af3fe52986e4f1.tar.gz
gentoo-2-a1563af54def9b998cbcd6aed4af3fe52986e4f1.tar.bz2
gentoo-2-a1563af54def9b998cbcd6aed4af3fe52986e4f1.zip
Version bump, some new features including support for source files with same name but different extension (file.c/file.m), add dodoc for readme and release notes
(Portage version: 2.2_rc18/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog10
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.0.7.ebuild79
2 files changed, 88 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index af92e3d76179..53f58893cb2a 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnustep-base/gnustep-make
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.78 2008/10/03 17:14:01 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.79 2008/12/22 12:54:26 voyageur Exp $
+
+*gnustep-make-2.0.7 (22 Dec 2008)
+
+ 22 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-make-2.0.7.ebuild:
+ Version bump, some new features including support for source files with
+ same name but different extension (file.c/file.m), add dodoc for readme
+ and release notes
03 Oct 2008; Friedrich Oslage <bluebird@gentoo.org>
gnustep-make-2.0.6.ebuild:
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.0.7.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.0.7.ebuild
new file mode 100644
index 000000000000..da42439e808b
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.0.7.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.0.7.ebuild,v 1.1 2008/12/22 12:54:26 voyageur Exp $
+
+EAPI=2
+
+inherit gnustep-base eutils
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ sys-devel/gcc[objc]
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=${GNUSTEP_PREFIX} --with-layout=gnustep"
+ myconf="$myconf --with-config-file=/etc/GNUstep/GNUstep.conf"
+ myconf="$myconf --enable-native-objc-exceptions"
+ econf $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake || die "compilation failed"
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ cd Documentation
+ emake -j1 all install || die "doc make has failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval="-j1"
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${D}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ dodoc FAQ README RELEASENOTES
+
+ exeinto /etc/profile.d
+ doexe "${FILESDIR}"/gnustep-2.sh
+ doexe "${FILESDIR}"/gnustep-2.csh
+
+ dodir /etc/env.d
+ cat <<- EOF > "${D}"/etc/env.d/99gnustep
+PATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+ROOTPATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+LDPATH=${GNUSTEP_SYSTEM_LIBRARIES}:${GNUSTEP_LOCAL_LIBRARIES}
+MANPATH=${GNUSTEP_SYSTEM_DOC_MAN}:${GNUSTEP_LOCAL_DOC_MAN}
+INFOPATH=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+INFODIR=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+EOF
+}