summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-09-27 00:20:17 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-09-27 00:20:17 +0000
commitbfb754d5e3ad3a77cdc9b3616e691d32ad524975 (patch)
tree1fd511500780732a6e3a793ab52bbfee7f592be2 /gnustep-base
parentNew package; key'd for ~x86. (Manifest recommit) (diff)
downloadgentoo-2-bfb754d5e3ad3a77cdc9b3616e691d32ad524975.tar.gz
gentoo-2-bfb754d5e3ad3a77cdc9b3616e691d32ad524975.tar.bz2
gentoo-2-bfb754d5e3ad3a77cdc9b3616e691d32ad524975.zip
Added support for gnustep-libs/camaelon, via a local use flag (patches in support). Camaelon is a GNUstep theme engine.
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog7
-rw-r--r--gnustep-base/gnustep-gui/files/gnustep-gui-0.9.4-camaelon.patch121
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild14
3 files changed, 139 insertions, 3 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index 85287c88d2f0..5f95f3c5489a 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/gnustep-gui
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.7 2004/09/26 02:46:23 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.8 2004/09/27 00:20:17 fafhrd Exp $
+
+ 26 Sep 2004; Armando Di Cianno <fafhrd@gentoo.org>
+ +files/gnustep-gui-0.9.4-camaelon.patch, gnustep-gui-0.9.4.ebuild:
+ New local USE flag 'camaelon' patches in support for Camaelon GNUstep theme
+ engine; PDEPEND added if this USE flag is on for gnustep-libs/camaelon.
25 Sep 2004; Armando Di Cianno <fafhrd@gentoo.org> gnustep-gui-0.9.4.ebuild:
Made library depends less strict.
diff --git a/gnustep-base/gnustep-gui/files/gnustep-gui-0.9.4-camaelon.patch b/gnustep-base/gnustep-gui/files/gnustep-gui-0.9.4-camaelon.patch
new file mode 100644
index 000000000000..7768893ced1f
--- /dev/null
+++ b/gnustep-base/gnustep-gui/files/gnustep-gui-0.9.4-camaelon.patch
@@ -0,0 +1,121 @@
+diff -ur gnustep-gui-0.9.4/Source/Functions.m gnustep-gui-0.9.4-testing/Source/Functions.m
+--- gnustep-gui-0.9.4/Source/Functions.m 2004-02-08 08:07:24.000000000 -0500
++++ gnustep-gui-0.9.4-testing/Source/Functions.m 2004-09-26 18:32:02.192773040 -0400
+@@ -573,9 +573,9 @@
+ up_sides, grays, 6);
+ }
+
+- DPSsetgray(ctxt, NSLightGray);
+- DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
+- NSWidth(rect), NSHeight(rect));
++// DPSsetgray(ctxt, NSLightGray);
++// DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
++// NSWidth(rect), NSHeight(rect));
+ }
+
+ void
+@@ -609,9 +609,9 @@
+ DPSrectfill(ctxt, NSMaxX(aRect) - 2., NSMaxY(aRect) - 2., 1., 1.);
+ }
+
+- DPSsetgray(ctxt, NSLightGray);
+- DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
+- NSWidth(rect), NSHeight(rect));
++// DPSsetgray(ctxt, NSLightGray);
++// DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
++// NSWidth(rect), NSHeight(rect));
+ }
+
+ void
+@@ -637,9 +637,9 @@
+ up_sides, grays, 8);
+ }
+
+- DPSsetgray(ctxt, NSLightGray);
+- DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
+- NSWidth(rect), NSHeight(rect));
++// DPSsetgray(ctxt, NSLightGray);
++// DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
++// NSWidth(rect), NSHeight(rect));
+ }
+
+ void
+@@ -665,9 +665,9 @@
+ up_sides, grays, 8);
+ }
+
+- DPSsetgray(ctxt, NSWhite);
+- DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
+- NSWidth(rect), NSHeight(rect));
++// DPSsetgray(ctxt, NSWhite);
++// DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
++// NSWidth(rect), NSHeight(rect));
+ }
+
+ void
+@@ -771,9 +771,9 @@
+ up_sides, grays, 6);
+ }
+
+- DPSsetgray(ctxt, NSLightGray);
+- DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
+- NSWidth(rect), NSHeight(rect));
++// DPSsetgray(ctxt, NSLightGray);
++// DPSrectfill(ctxt, NSMinX(rect), NSMinY(rect),
++// NSWidth(rect), NSHeight(rect));
+ }
+
+ void
+Only in gnustep-gui-0.9.4-testing/Source: Functions.m.orig
+diff -ur gnustep-gui-0.9.4/Source/NSApplication.m gnustep-gui-0.9.4-testing/Source/NSApplication.m
+--- gnustep-gui-0.9.4/Source/NSApplication.m 2004-07-22 19:57:46.000000000 -0400
++++ gnustep-gui-0.9.4-testing/Source/NSApplication.m 2004-09-26 19:02:03.996857184 -0400
+@@ -223,6 +223,27 @@
+ [backend initializeBackend];
+ }
+
++ /* hack to load arbitrary bundles - Alexander Malmberg 2002-05-09 */
++ {
++ NSUserDefaults *defs=[NSUserDefaults standardUserDefaults];
++ NSString *s=[defs stringForKey: @"GUIThemeBundles"];
++ NSArray *a=[s componentsSeparatedByString: @" "];
++ int i,c=[a count];
++
++ NSLog(@"try loading '%@'",s);
++ for (i=0;i<c;i++)
++ {
++ NSLog(@"try '%@'\n",[a objectAtIndex: i]);
++ NSBundle *b=[NSBundle bundleWithPath: [a objectAtIndex: i]];
++ if (!b)
++ {
++ NSLog(@"Couldn't load theme bundle '%@'!",[a objectAtIndex: i]);
++ continue;
++ }
++ [[[b principalClass] alloc] init];
++ }
++ }
++
+ #else
+ /* GSBackend will be in a separate library, so use the runtime
+ to find the class and avoid an unresolved reference problem */
+Only in gnustep-gui-0.9.4-testing/Source: NSApplication.m.orig
+Only in gnustep-gui-0.9.4-testing/Source: NSApplication.m.rej
+Only in gnustep-gui-0.9.4-testing/Source: NSApplication.m~
+diff -ur gnustep-gui-0.9.4/Source/NSColor.m gnustep-gui-0.9.4-testing/Source/NSColor.m
+--- gnustep-gui-0.9.4/Source/NSColor.m 2004-01-30 14:49:00.000000000 -0500
++++ gnustep-gui-0.9.4-testing/Source/NSColor.m 2004-09-26 18:32:02.191773192 -0400
+@@ -713,6 +713,13 @@
+ return systemColorWithName(@"windowFrameTextColor");
+ }
+
+++ (void) setColor: (NSColor*) color forKey: (NSString*) key
++{
++ [systemColors setColor: color forKey: key];
++ [[systemDict objectForKey: key] recache];
++}
++
++
+ ////////////////////////////////////////////////////////////
+ //
+ // Instance methods
+Only in gnustep-gui-0.9.4-testing/Source: NSColor.m.orig
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild
index 8a8a0fdcd464..b558fb9545bc 100644
--- a/gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild,v 1.3 2004/09/26 02:46:23 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.9.4.ebuild,v 1.4 2004/09/27 00:20:17 fafhrd Exp $
inherit gnustep
@@ -12,7 +12,7 @@ KEYWORDS="~x86"
SLOT="0"
LICENSE="LGPL-2.1"
-IUSE="${IUSE} jpeg gif png gsnd doc cups"
+IUSE="${IUSE} jpeg gif png gsnd doc cups camaelon"
DEPEND="${GNUSTEP_BASE_DEPEND}
virtual/x11
=media-libs/tiff-3*
@@ -24,6 +24,16 @@ DEPEND="${GNUSTEP_BASE_DEPEND}
=app-text/aspell-0.50*"
RDEPEND="${DEPEND}
${DOC_RDEPEND}"
+PDEPEND="camaelon? =gnustep-libs/camaelon-0.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use camaelon
+ then
+ epatch ${FILESDIR}/${P}-camaelon.patch
+ fi
+}
src_compile() {
egnustep_env