summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-14 18:49:56 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-14 18:49:56 +0000
commitd53cfd3b16ddf6a3bb8b2a5a4afdb222b7e48e19 (patch)
treea849f017d1ce4a7542e3ea74e3236fcb20670533 /gnustep-base
parentRevbump as I missed that the dir is not acutally propagated. (diff)
downloadgentoo-2-d53cfd3b16ddf6a3bb8b2a5a4afdb222b7e48e19.tar.gz
gentoo-2-d53cfd3b16ddf6a3bb8b2a5a4afdb222b7e48e19.tar.bz2
gentoo-2-d53cfd3b16ddf6a3bb8b2a5a4afdb222b7e48e19.zip
Fix deps, add boehm-gc support
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog8
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.6.ebuild19
-rw-r--r--gnustep-base/libobjc2/metadata.xml4
3 files changed, 21 insertions, 10 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index cd9cb7961bdf..9c871327d2a1 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-base/libobjc2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.7 2011/11/24 10:54:08 voyageur Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.8 2012/02/14 18:49:56 voyageur Exp $
+
+ 14 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> libobjc2-1.6.ebuild,
+ metadata.xml:
+ Fix deps, add boehm-gc support
*libobjc2-1.6 (24 Nov 2011)
diff --git a/gnustep-base/libobjc2/libobjc2-1.6.ebuild b/gnustep-base/libobjc2/libobjc2-1.6.ebuild
index e88e4daa1c58..8d86be5170c4 100644
--- a/gnustep-base/libobjc2/libobjc2-1.6.ebuild
+++ b/gnustep-base/libobjc2/libobjc2-1.6.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.6.ebuild,v 1.1 2011/11/24 10:54:08 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.6.ebuild,v 1.2 2012/02/14 18:49:56 voyageur Exp $
EAPI=4
inherit multilib
# We need gnustep-make, but gnustep-make can depend on libobjc
# Use a temporary setup to install in /usr/
-GSMAKE=gnustep-make-2.6.1
+GSMAKE=gnustep-make-2.6.2
DESCRIPTION="GNUstep Objective-C runtime"
HOMEPAGE="http://www.gnustep.org"
SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
@@ -16,11 +16,10 @@ SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+boehm-gc"
-DEPEND=">=sys-devel/gcc-3.3[objc]
- >=sys-devel/make-3.75"
-RDEPEND=""
+DEPEND="boehm-gc? ( dev-libs/boehm-gc )"
+RDEPEND="${DEPEND}"
GSMAKE_S=${WORKDIR}/${GSMAKE}
@@ -37,7 +36,11 @@ src_configure() {
}
src_compile() {
- emake GNUSTEP_MAKEFILES="${GSMAKE_S}" messages=yes
+ local gb
+ use boehm-gc \
+ && gb="boehm_gc=yes" \
+ || gb="boehm_gc=no"
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" messages=yes ${gb}
}
src_install() {
diff --git a/gnustep-base/libobjc2/metadata.xml b/gnustep-base/libobjc2/metadata.xml
index 6d5c816014c3..add917dae4e5 100644
--- a/gnustep-base/libobjc2/metadata.xml
+++ b/gnustep-base/libobjc2/metadata.xml
@@ -24,4 +24,8 @@ Both ABIs support the following feature above and beyond the GCC runtime:
- Type-dependent dispatch, eliminating stack corruption from mismatched
selectors.
</longdescription>
+<use>
+ <flag name='boehm-gc'>Enable Hans Boehm's garbage collector
+ (<pkg>dev-libs/boehm-gc</pkg>)</flag>
+</use>
</pkgmetadata>