summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-12-08 18:01:38 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-12-08 18:01:38 +0000
commit5e5f8b0dc9e3657d8e02c7b8ee6ba0cc6ff58fd7 (patch)
tree74213e240a4bbc0fa30632ebcacfb0a05e6f5952 /gnustep-libs/gdl2/gdl2-0.11.0.ebuild
parentStable for HPPA (bug #201438). (diff)
downloadgentoo-2-5e5f8b0dc9e3657d8e02c7b8ee6ba0cc6ff58fd7.tar.gz
gentoo-2-5e5f8b0dc9e3657d8e02c7b8ee6ba0cc6ff58fd7.tar.bz2
gentoo-2-5e5f8b0dc9e3657d8e02c7b8ee6ba0cc6ff58fd7.zip
Version bump, ebuild cleanup, add sqlite support
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'gnustep-libs/gdl2/gdl2-0.11.0.ebuild')
-rw-r--r--gnustep-libs/gdl2/gdl2-0.11.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnustep-libs/gdl2/gdl2-0.11.0.ebuild b/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
new file mode 100644
index 000000000000..dbab22ee1c55
--- /dev/null
+++ b/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/gdl2/gdl2-0.11.0.ebuild,v 1.1 2007/12/08 18:01:38 voyageur Exp $
+
+inherit gnustep-2
+
+MY_P="gnustep-dl2-${PV}"
+DESCRIPTION="GNUstep Database Library 2 (GDL2) for mapping Obj-C to RDBMSes"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="postgres sqlite"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="!gnustep-apps/sope
+ postgres? ( dev-db/libpq )
+ sqlite? ( dev-db/sqlite )"
+RDEPEND="${DEPEND}"