summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-10-13 15:08:44 +0000
committerDan Armak <danarmak@gentoo.org>2005-10-13 15:08:44 +0000
commit5e701f1b73cdb2b79272e032438917a4ee0d7e32 (patch)
tree3414a6e8763136a9831e42cd9a076c260192a5bb /kde-base/akode/akode-3.4.3.ebuild
parentMasked pmount (diff)
downloadgentoo-2-5e701f1b73cdb2b79272e032438917a4ee0d7e32.tar.gz
gentoo-2-5e701f1b73cdb2b79272e032438917a4ee0d7e32.tar.bz2
gentoo-2-5e701f1b73cdb2b79272e032438917a4ee0d7e32.zip
fix compilation: added missing dep on kdemultimedia-arts and KMCOPYLIB instructions for USE=arts.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'kde-base/akode/akode-3.4.3.ebuild')
-rw-r--r--kde-base/akode/akode-3.4.3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/kde-base/akode/akode-3.4.3.ebuild b/kde-base/akode/akode-3.4.3.ebuild
index 842d2034768e..19b1a0c8b8a2 100644
--- a/kde-base/akode/akode-3.4.3.ebuild
+++ b/kde-base/akode/akode-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.3.ebuild,v 1.1 2005/10/13 00:09:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.3.ebuild,v 1.2 2005/10/13 15:08:44 danarmak Exp $
KMNAME=kdemultimedia
MAXKDEVER=$PV
@@ -10,7 +10,7 @@ inherit kde-meta
DESCRIPTION="aRts plugins for various formats"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa arts flac jack mp3 speex vorbis"
-DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) $(deprange 3.4.1 $MAXKDEVER kde-base/kdemultimedia-arts) )
flac? ( media-libs/flac )
vorbis? ( media-sound/vorbis-tools )
speex? ( media-libs/speex )
@@ -23,6 +23,8 @@ DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
# MISSING: polypaudio - no gentoo ebuild as yet
# TODO: configure needs a pkg-config file for media-sound/jack to detect it
+KMCOPYLIB="libartsbuilder arts/runtime"
+
src_compile() {
use speex && myconf="$myconf --with-extra-includes=/usr/include/speex"
myconf="$myconf $(use_with mp3 libmad) $(use_with flac) $(use_with speex)