summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-10 05:26:53 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-10 05:26:53 +0000
commit58fe2b077cccff14c09c87ab984f44e735ecae92 (patch)
tree598399c0caa1a9be91499e1b69b8cb0100a9b16c /kde-base/akonadi/akonadi-4.4.11.1.ebuild
parentRemove unneeded useflag descriptions from metadata.xml (diff)
downloadgentoo-2-58fe2b077cccff14c09c87ab984f44e735ecae92.tar.gz
gentoo-2-58fe2b077cccff14c09c87ab984f44e735ecae92.tar.bz2
gentoo-2-58fe2b077cccff14c09c87ab984f44e735ecae92.zip
Actually add 4.4.11.1 this time.
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/akonadi/akonadi-4.4.11.1.ebuild')
-rw-r--r--kde-base/akonadi/akonadi-4.4.11.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-base/akonadi/akonadi-4.4.11.1.ebuild b/kde-base/akonadi/akonadi-4.4.11.1.ebuild
new file mode 100644
index 000000000000..f812abdf9735
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.4.11.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.4.11.1.ebuild,v 1.12 2013/10/10 05:26:49 creffett Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+HOMEPAGE="http://pim.kde.org/akonadi"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ >=app-office/akonadi-server-1.3.1
+ $(add_kdebase_dep kdelibs 'semantic-desktop(+)' 4.6)
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop(+)' 4.6)
+ $(add_kdebase_dep libkdepim)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+KMEXTRA="
+ akonadiconsole/
+"
+
+# @since 4.3 - blocks kdemaildir - no longer provided (it's in akonadi now)
+add_blocker kdemaildir
+add_blocker kdepim-kresources '<4.2.95'
+# bug #428182
+add_blocker akonadiconsole
+
+src_configure() {
+ mycmakeargs=(
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces"
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/services"
+ )
+
+ kde4-meta_src_configure
+}