summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2006-03-22 20:15:49 +0000
committerDan Armak <danarmak@gentoo.org>2006-03-22 20:15:49 +0000
commit0979cc06b444f923bca22380a0a58f4a9b8ce2a4 (patch)
tree0f28cd6d7172f7619565520d1c2e67fcd733f729 /kde-base/kaddressbook/kaddressbook-3.5.2.ebuild
parentAdd ~amd64 keyword. Builds and runs as expected. (diff)
downloadgentoo-2-0979cc06b444f923bca22380a0a58f4a9b8ce2a4.tar.gz
gentoo-2-0979cc06b444f923bca22380a0a58f4a9b8ce2a4.tar.bz2
gentoo-2-0979cc06b444f923bca22380a0a58f4a9b8ce2a4.zip
KDE 3.5.2 - not yet released upstream, package.masked
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'kde-base/kaddressbook/kaddressbook-3.5.2.ebuild')
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.5.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/kde-base/kaddressbook/kaddressbook-3.5.2.ebuild b/kde-base/kaddressbook/kaddressbook-3.5.2.ebuild
new file mode 100644
index 000000000000..a6d95da39d8d
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-3.5.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5.2.ebuild,v 1.1 2006/03/22 20:14:54 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnokii"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/certmanager)
+$(deprange 3.5.0 $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)
+gnokii? ( app-mobilephone/gnokii )"
+
+myconf="$myconf $(use_with gnokii)"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkcal libkcal
+ libkleopatra certmanager/lib/
+ libqgpgme libkdenetwork/qgpgme/
+ libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ certmanager/
+ kontact/interfaces/
+ akregator
+ kmail/kmailIface.h"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/
+ akregator/src/librss"
+ # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+ kabc/
+ kfile-plugins/vcf
+ kontact/plugins/kaddressbook"
+
+src_compile() {
+ export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd ${S}/libkcal/libical/src/libical && make ical.h
+ # generate "icalss.h"
+ cd ${S}/libkcal/libical/src/libicalss && make icalss.h
+
+ kde-meta_src_compile "make"
+}