summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
commitd7e1a4366ff9ba481421bd6f31539139be38e99a (patch)
tree06cf6fc3ad2522bd965c90e770efaf564b4caf81 /kde-base/kajongg
parentMask KDE SC 4.10.0 for keywording bug #455960 (diff)
downloadgentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.gz
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.bz2
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.zip
Add KDE SC 4.10.0
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/kajongg')
-rw-r--r--kde-base/kajongg/ChangeLog7
-rw-r--r--kde-base/kajongg/kajongg-4.10.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kajongg/ChangeLog b/kde-base/kajongg/ChangeLog
index e589630ab2a1..718b8ba94704 100644
--- a/kde-base/kajongg/ChangeLog
+++ b/kde-base/kajongg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kajongg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kajongg/ChangeLog,v 1.81 2013/01/28 12:12:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kajongg/ChangeLog,v 1.82 2013/02/07 04:57:55 alexxy Exp $
+
+*kajongg-4.10.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org> +kajongg-4.10.0.ebuild:
+ Version bump KDE SC 4.10.0
28 Jan 2013; Agostino Sarubbo <ago@gentoo.org> -kajongg-4.9.3.ebuild,
-kajongg-4.9.4.ebuild:
diff --git a/kde-base/kajongg/kajongg-4.10.0.ebuild b/kde-base/kajongg/kajongg-4.10.0.ebuild
new file mode 100644
index 000000000000..46f4c6d8af62
--- /dev/null
+++ b/kde-base/kajongg/kajongg-4.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kajongg/kajongg-4.10.0.ebuild,v 1.1 2013/02/07 04:57:55 alexxy Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_DEPEND="2:2.6"
+inherit kde4-base python
+
+DESCRIPTION="The classical Mah Jongg for four players"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-db/sqlite:3
+ $(add_kdebase_dep libkdegames)
+ $(add_kdebase_dep pykde4)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep libkmahjongg)
+ >=dev-python/twisted-8.2.0
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 src
+ kde4-base_src_prepare
+}