summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-27 22:12:47 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-27 22:12:47 +0000
commit1086571098d06edc4c0fbaa1378e9be16a97c7e2 (patch)
tree9670edbde2439f82989a197c51128ae72736ef1f /kde-base/kalarm
parentInstall additional scripts. Thanks to fleg <fleg@lavabit.com> for the patches... (diff)
downloadgentoo-2-1086571098d06edc4c0fbaa1378e9be16a97c7e2.tar.gz
gentoo-2-1086571098d06edc4c0fbaa1378e9be16a97c7e2.tar.bz2
gentoo-2-1086571098d06edc4c0fbaa1378e9be16a97c7e2.zip
Added upstream patch against a crash, bug 365139
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalarm')
-rw-r--r--kde-base/kalarm/ChangeLog8
-rw-r--r--kde-base/kalarm/files/kalarm-4.4.11.1-crash.patch34
-rw-r--r--kde-base/kalarm/kalarm-4.4.11.1-r1.ebuild35
3 files changed, 76 insertions, 1 deletions
diff --git a/kde-base/kalarm/ChangeLog b/kde-base/kalarm/ChangeLog
index d239dc2e4d82..52a3cc1b97e4 100644
--- a/kde-base/kalarm/ChangeLog
+++ b/kde-base/kalarm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalarm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/ChangeLog,v 1.173 2011/04/23 17:12:48 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/ChangeLog,v 1.174 2011/04/27 22:12:47 dilfridge Exp $
+
+*kalarm-4.4.11.1-r1 (27 Apr 2011)
+
+ 27 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kalarm-4.4.11.1-r1.ebuild, +files/kalarm-4.4.11.1-crash.patch:
+ Added upstream patch against a crash, bug 365139
*kalarm-4.5.95 (23 Apr 2011)
diff --git a/kde-base/kalarm/files/kalarm-4.4.11.1-crash.patch b/kde-base/kalarm/files/kalarm-4.4.11.1-crash.patch
new file mode 100644
index 000000000000..2c05d750dea7
--- /dev/null
+++ b/kde-base/kalarm/files/kalarm-4.4.11.1-crash.patch
@@ -0,0 +1,34 @@
+diff --git a/kalarm/lib/spinbox2.cpp b/kalarm/lib/spinbox2.cpp
+index cc10882..f1e8ab9 100644
+--- a/kalarm/lib/spinbox2.cpp
++++ b/kalarm/lib/spinbox2.cpp
+@@ -1,7 +1,7 @@
+ /*
+ * spinbox2.cpp - spin box with extra pair of spin buttons (for Qt 3)
+ * Program: kalarm
+- * Copyright © 2001-2009 by David Jarvie <djarvie@kde.org>
++ * Copyright © 2001-2009,2011 by David Jarvie <djarvie@kde.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+@@ -28,7 +28,7 @@
+ #include <QMouseEvent>
+ #include <QStyleOptionSpinBox>
+ #include <QGraphicsPixmapItem>
+-#include <QPaintEngine>
++#include <QPainter>
+ #include <QTimer>
+ #include <QFrame>
+ #include <QBrush>
+@@ -588,8 +588,9 @@ void SpinMirror::setFrame()
+ p = grabWidget(mMainSpinbox, QRect(x, 0, 1, height()));
+ // Blot out edit field stuff from the middle of the slice
+ QPixmap dot = grabWidget(mMainSpinbox, QRect(x, editOffsetY, 1, 1));
+- QPaintEngine* pe = p.paintEngine();
+- pe->drawTiledPixmap(QRectF(0, editOffsetY, 1, height() - 2*editOffsetY), dot, QPointF(0, 0));
++ QPainter painter(&p);
++ painter.drawTiledPixmap(0, editOffsetY, 1, height() - 2*editOffsetY, dot, 0, 0);
++ painter.end();
+ // Horizontally fill the mirror widget with the vertical slice
+ p = p.scaled(size());
+ // Grab the left hand border of the main spinbox, and draw it into the mirror widget.
diff --git a/kde-base/kalarm/kalarm-4.4.11.1-r1.ebuild b/kde-base/kalarm/kalarm-4.4.11.1-r1.ebuild
new file mode 100644
index 000000000000..bd57f172b1ba
--- /dev/null
+++ b/kde-base/kalarm/kalarm-4.4.11.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/kalarm-4.4.11.1-r1.ebuild,v 1.1 2011/04/27 22:12:47 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="Personal alarm message, command and email scheduler for KDE"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+RDEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep libkdepim)
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+"
+
+KMEXTRACTONLY="
+ kmail/
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.4.11.1-crash.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_akonadi=OFF
+ -DXSLTPROC_EXECUTABLE="${EPREFIX}"/usr/bin/xsltproc
+ )
+ kde4-meta_src_configure
+}