summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
committerDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
commit2c22cfa8ffcfc73043bf37aeee39170605f0eb4d (patch)
treed056634258bce285b9c3837f09ef42145572f845 /kde-base/kalarm
parentAdd the missing HOMEPAGE variable so repoman doesn't complain. (diff)
downloadgentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.tar.gz
gentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.tar.bz2
gentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.zip
KDE 3.4.1 ebuilds; package.masked as they aren't released yet
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'kde-base/kalarm')
-rw-r--r--kde-base/kalarm/ChangeLog8
-rw-r--r--kde-base/kalarm/Manifest4
-rw-r--r--kde-base/kalarm/files/digest-kalarm-3.4.12
-rw-r--r--kde-base/kalarm/kalarm-3.4.1.ebuild45
4 files changed, 57 insertions, 2 deletions
diff --git a/kde-base/kalarm/ChangeLog b/kde-base/kalarm/ChangeLog
index 1ff966bff47b..152709d4cb8e 100644
--- a/kde-base/kalarm/ChangeLog
+++ b/kde-base/kalarm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalarm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/ChangeLog,v 1.8 2005/04/27 19:04:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/ChangeLog,v 1.9 2005/05/25 21:23:00 danarmak Exp $
+
+*kalarm-3.4.1 (25 May 2005)
+
+ 25 May 2005; Dan Armak <danarmak@gentoo.org> +kalarm-3.4.1.ebuild:
+ Ebuilds for KDE 3.4.1. These are package.masked until 3.4.1 is actually
+ released. You can't get the tarballs yet.
27 Apr 2005; Markus Rothe <corsair@gentoo.org> kalarm-3.4.0.ebuild:
Added ~ppc64 to KEYWORDS
diff --git a/kde-base/kalarm/Manifest b/kde-base/kalarm/Manifest
index c1c85275f2b5..478af63941f2 100644
--- a/kde-base/kalarm/Manifest
+++ b/kde-base/kalarm/Manifest
@@ -1,4 +1,6 @@
-MD5 0b0e8915fd69004061409e5568a0c8a3 ChangeLog 1428
MD5 b421f9636951854c37256688353143f1 kalarm-3.4.0.ebuild 1313
+MD5 0b0e8915fd69004061409e5568a0c8a3 ChangeLog 1428
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
+MD5 0a5108e80225ae3f8cacb1044387350b kalarm-3.4.1.ebuild 1294
MD5 8c0ffea7b75b42449f4acada755ff36a files/digest-kalarm-3.4.0 67
+MD5 7e3e5fdc63982b39b9df921e916f246a files/digest-kalarm-3.4.1 134
diff --git a/kde-base/kalarm/files/digest-kalarm-3.4.1 b/kde-base/kalarm/files/digest-kalarm-3.4.1
new file mode 100644
index 000000000000..50c8351c10a7
--- /dev/null
+++ b/kde-base/kalarm/files/digest-kalarm-3.4.1
@@ -0,0 +1,2 @@
+MD5 7f8cc9a40c0190c5a6723f6325bcba06 kdepim-3.4.0.tar.bz2 11441545
+MD5 e5515aa230558bac8651e9cd9f8f9673 kdepim-3.4.1.tar.bz2 11345538
diff --git a/kde-base/kalarm/kalarm-3.4.1.ebuild b/kde-base/kalarm/kalarm-3.4.1.ebuild
new file mode 100644
index 000000000000..e85e4d9da38a
--- /dev/null
+++ b/kde-base/kalarm/kalarm-3.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/kalarm-3.4.1.ebuild,v 1.1 2005/05/25 21:23:00 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="Personal alarm message, command and email scheduler for KDE"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+OLDDEPEND="~kde-base/libkdepim-$PV
+ ~kde-base/libkdenetwork-$PV
+ ~kde-base/libkcal-$PV"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/libkmime)
+$(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkmime libkmime
+ libkpimidentities libkpimidentities"
+KMEXTRACTONLY="
+ libkcal/libical
+ libkdepim/
+ libkdenetwork/
+ libkpimidentities/
+ libkmime/"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/"
+
+src_compile() {
+ export DO_NOT_COMPILE="libkcal" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd ${S}/libkcal/libical/src/libical && make ical.h
+ # generate "icalss.h"
+ cd ${S}/libkcal/libical/src/libicalss && make icalss.h
+
+ kde-meta_src_compile make
+} \ No newline at end of file