summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 22:34:30 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 22:34:30 +0000
commitdce04c76628a29cf5ba2c48e0156be00a8a63bd8 (patch)
treea6e85ea19031bb6629df07ef0948409f51f4c9da /kde-base/kalyptus/kalyptus-3.5.9.ebuild
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-dce04c76628a29cf5ba2c48e0156be00a8a63bd8.tar.gz
gentoo-2-dce04c76628a29cf5ba2c48e0156be00a8a63bd8.tar.bz2
gentoo-2-dce04c76628a29cf5ba2c48e0156be00a8a63bd8.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kalyptus/kalyptus-3.5.9.ebuild')
-rw-r--r--kde-base/kalyptus/kalyptus-3.5.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/kalyptus/kalyptus-3.5.9.ebuild b/kde-base/kalyptus/kalyptus-3.5.9.ebuild
new file mode 100644
index 000000000000..94e79a20bca0
--- /dev/null
+++ b/kde-base/kalyptus/kalyptus-3.5.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalyptus/kalyptus-3.5.9.ebuild,v 1.1 2008/02/20 22:34:30 philantrop Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="KDE bindings generator for multiple languages."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+
+PATCHES="${FILESDIR}/${P}-fix_makefile.patch"
+
+MY_S="${WORKDIR}/${P}/${PN}"
+
+# Weird build system, weirder errors.
+# You're welcome to fix this in a better way --danarmak
+# Still weird, but changed. :)
+src_compile () {
+ S="${MY_S}"
+ cd "${S}"
+ emake -f Makefile.cvs
+ ./configure --prefix=$(kde-config --prefix)
+ emake
+}
+
+src_install() {
+ S="${MY_S}"
+ cd "${S}"
+ emake install DESTDIR="$D"
+}