summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-06 18:23:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-06 18:23:28 +0000
commit4f373aa228b7f8e2c055f7482595ff4a4f5ffb3d (patch)
tree8de02a46478392322779f292b160ba4720ddc6fa /kde-base/kalzium
parentUpdated with gtk-2 dependency, see bug #204621. Warning: still buggy. (diff)
downloadgentoo-2-4f373aa228b7f8e2c055f7482595ff4a4f5ffb3d.tar.gz
gentoo-2-4f373aa228b7f8e2c055f7482595ff4a4f5ffb3d.tar.bz2
gentoo-2-4f373aa228b7f8e2c055f7482595ff4a4f5ffb3d.zip
Add a check for native code ocaml compiler and facile library
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-3.5.8.ebuild22
2 files changed, 24 insertions, 5 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 5bd509342316..25273dbb739b 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kalzium
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.75 2007/10/19 21:54:55 philantrop Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.76 2008/01/06 18:23:28 aballier Exp $
+
+ 06 Jan 2008; Alexis Ballier <aballier@gentoo.org> kalzium-3.5.8.ebuild:
+ Add a check for native code ocaml compiler and facile library
*kalzium-3.5.8 (19 Oct 2007)
diff --git a/kde-base/kalzium/kalzium-3.5.8.ebuild b/kde-base/kalzium/kalzium-3.5.8.ebuild
index d7d075e09b59..c83ac13d57bb 100644
--- a/kde-base/kalzium/kalzium-3.5.8.ebuild
+++ b/kde-base/kalzium/kalzium-3.5.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-3.5.8.ebuild,v 1.1 2007/10/19 21:54:55 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-3.5.8.ebuild,v 1.2 2008/01/06 18:23:28 aballier Exp $
KMNAME=kdeedu
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
-inherit flag-o-matic kde-meta
+inherit flag-o-matic kde-meta eutils
DESCRIPTION="KDE: periodic table of the elements"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
@@ -21,6 +21,22 @@ KMCOPYLIB="libkdeeduplot libkdeedu/kdeeduplot
PATCHES="${FILESDIR}/${PN}-3.5.7-copy_string.patch"
+pkg_setup() {
+ if use solver && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-lang/ocaml built with the ocamlopt useflag"
+ eerror "in order to get a native code ocaml compiler"
+ die "Please install dev-lang/ocaml with ocamlopt support"
+ fi
+ if use solver && ! built_with_use --missing true dev-ml/facile ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-ml/facile built with the ocamlopt useflag"
+ eerror "in order to get the native code library"
+ die "Please install dev-ml/facile with ocamlopt support"
+ fi
+ kde_pkg_setup
+}
+
src_compile() {
append-ldflags -Wl,-z,noexecstack